Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#61399 closed defect (duplicate)

libgcc10: library not found for -lgcc_s.10.4

Reported by: mf2k (Frank Schima) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: bigsur Cc: OliverUrbann (Oliver Urbann), sudheerhebbale (Sudheer Hebbale)
Port: libgcc10

Description

running Xcode 12.1 on Big Sur public beta

Error appears to be:

:info:build libtool: link:  /opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/./gcc/xgcc -shared-libgcc -B/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/./gcc -nostdinc++ -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/src -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/src/.libs -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/libsupc++/.libs -B/opt/local/x86_64-apple-darwin20/bin/ -B/opt/local/x86_64-apple-darwin20/lib/ -isystem /opt/local/x86_64-apple-darwin20/include -isystem /opt/local/x86_64-apple-darwin20/sys-include   -fno-checking -dynamiclib  -o .libs/libstdc++.6.dylib .libs/libstdc++.6.dylib-master.o  -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/libsupc++/.libs -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/src -L/opt/local/var/macports/build/_opt_mports_macports-ports_lang_gcc10/libgcc10/work/build/x86_64-apple-darwin20/libstdc++-v3/src/.libs -lm  -Wl,-exported_symbols_list -Wl,libstdc++-symbols.explist   -install_name  /opt/local/lib/libgcc/libstdc++.6.dylib -compatibility_version 7 -current_version 7.28
:info:build xgcc: warning: couldn't understand version 11.0
:info:build ld: library not found for -lgcc_s.10.4

Attachments (1)

main.log.zip (1.7 MB) - added by mf2k (Frank Schima) 13 months ago.

Download all attachments as: .zip

Change History (7)

Changed 13 months ago by mf2k (Frank Schima)

Attachment: main.log.zip added

comment:1 Changed 13 months ago by kencu (Ken)

They removed that library (libgcc_s.10.4) from MacOS but gcc still references it.

A released version of gcc hasn't been fixed for >= 11.0, but there is an easily-found private repo that is headed up by the gcc darwin lead (Iain Sandoe) with a working gcc fork in it for both newer systems and for arm64. Jeremy and others are working on that with Iain, to be released when ready.

I would work on it too, but I have no BigSur system and no $$ for an arm64 mac Dev Kit right now, so ...

comment:2 Changed 13 months ago by ryandesign (Ryan Schmidt)

Cc: OliverUrbann added
Keywords: bigsur added

Has duplicate #61456.

comment:3 Changed 13 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #60908.

comment:4 Changed 13 months ago by sudheerhebbale (Sudheer Hebbale)

Cc: sudheerhebbale added

comment:5 Changed 13 months ago by sudheerhebbale (Sudheer Hebbale)

I have encountered this issue while building libgcc9.

However, the build of libgcc10 gcc10 went through

comment:6 Changed 13 months ago by kencu (Ken)

gcc10 was just recently patched on MacPorts as a temporary measure.

There are no plans to patch gcc9, however.

Note: See TracTickets for help on using tickets.