Opened 5 months ago

Closed 5 months ago

#61470 closed defect (duplicate)

Detex fails to build on Big Sur because of invalid implicit declaration in C99

Reported by: hnarayanan (Harish Narayanan) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: neilt (Neil Tiffin)
Port: detex

Description

The following is a snippet of the relevant error. Detex is not the only package that experiences this sort of compilation problem.

:info:build /usr/bin/clang -arch x86_64 -O  -DNO_MALLOC_DECL -Wno-return-type   -c -o detex.o detex.c
:info:build xxx.l:132:9: error: implicit declaration of function 'BeginEnv' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build {   if (BeginEnv("verbatim"))
:info:build         ^
:info:build xxx.l:144:13: error: implicit declaration of function 'BeginEnv' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build                                                   if (BeginEnv("minpage"))
:info:build                                                       ^
:info:build xxx.l:151:9: error: implicit declaration of function 'BeginEnv' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build {   if (BeginEnv(yytext))
:info:build         ^
:info:build xxx.l:164:31: error: implicit declaration of function 'EndEnv' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build /* end environment */   {   if (EndEnv(yytext))
:info:build                                 ^
:info:build xxx.l:271:5: error: implicit declaration of function 'IncludeFile' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build {   IncludeFile(yytext);
:info:build     ^
:info:build xxx.l:278:1: error: implicit declaration of function 'AddInclude' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build AddInclude(yytext);
:info:build ^
:info:build xxx.l:280:36: warning: expression which evaluates to zero treated as a null pointer constant of type 'char *' [-Wnon-literal-null-conversion]
:info:build                                                         rgsbIncList[csbIncList++] = '\0';
:info:build                                                                                     ^~~~
:info:build xxx.l:287:5: error: implicit declaration of function 'InputFile' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build {   InputFile(yytext);
:info:build     ^
:info:build xxx.l:372:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build main(cArgs,rgsbArgs)
:info:build ^
:info:build xxx.l:400:2: error: implicit declaration of function 'SetInputPaths' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build         SetInputPaths();
:info:build         ^
:info:build xxx.l:411:5: error: implicit declaration of function 'ErrorExit' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build                                 ErrorExit("-e option requires and argument");
:info:build                                 ^
:info:build xxx.l:436:4: error: implicit declaration of function 'Warning' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build                         Warning("unknown option ignored -", sbBadOpt);
:info:build                         ^
:info:build xxx.l:441:2: error: implicit declaration of function 'SetEnvIgnore' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build         SetEnvIgnore(sbEnvList);
:info:build         ^
:info:build xxx.l:447:3: error: implicit declaration of function 'Warning' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build                 Warning("can't open file", rgsbArgs[iArgs]);
:info:build                 ^
:info:build xxx.l:481:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build yywrap()
:info:build ^
:info:build xxx.l:520:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build SetEnvIgnore(sbEnvList)
:info:build ^
:info:build xxx.l:527:17: error: implicit declaration of function 'SeparateList' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build         csbEnvIgnore = SeparateList(sb, rgsbEnvIgnore, CHENVSEP, MAXENVS);
:info:build                        ^
:info:build xxx.l:529:6: error: implicit declaration of function 'ErrorExit' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build             ErrorExit("The environtment list contains too many environments");
:info:build             ^
:info:build xxx.l:537:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build BeginEnv(sbEnv)
:info:build ^
:info:build xxx.l:555:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build EndEnv(sbEnv)
:info:build ^
:info:build xxx.l:569:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build InputFile(sbFile)
:info:build ^
:info:build xxx.l:578:6: error: implicit declaration of function 'Warning' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build             Warning("can't open \\input file", sbFile);
:info:build             ^
:info:build xxx.l:593:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build IncludeFile(sbFile)
:info:build ^
:info:build xxx.l:600:7: error: implicit declaration of function 'InList' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build         if (!InList(sbFile))
:info:build              ^
:info:build xxx.l:604:6: error: implicit declaration of function 'Warning' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build             Warning("can't open \\include file", sbFile);
:info:build             ^
:info:build xxx.l:619:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build AddInclude(sbFile)
:info:build ^
:info:build xxx.l:625:6: error: implicit declaration of function 'Warning' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build             Warning("\\includeonly list is too long, ignoring", sbFile);
:info:build             ^
:info:build xxx.l:635:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build InList(sbFile)
:info:build ^
:info:build xxx.l:662:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
:info:build SetInputPaths()
:info:build ^
:info:build xxx.l:686:18: error: implicit declaration of function 'SeparateList' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
:info:build         csbInputPaths = SeparateList(sbPaths, rgsbInputPaths, CHPATHSEP, MAXINPUTPATHS);
:info:build                         ^
:info:build fatal error: too many errors emitted, stopping now [-ferror-limit=]
:info:build 11 warnings and 20 errors generated.
:info:build make: *** [detex.o] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_tex_detex/detex/work/detex-2.8'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_tex_detex/detex/work/detex-2.8" && /usr/bin/make -j8 -w all CC="/usr/bin/clang -arch x86_64" 
:info:build Exit code: 2

Change History (4)

comment:1 Changed 5 months ago by jmroot (Joshua Root)

Owner: set to ryandesign
Status: newassigned

comment:2 Changed 5 months ago by neilt (Neil Tiffin)

Yep, same here while trying to build octave.

detex @2.8_1

ProductName:	macOS
ProductVersion:	11.0.1
BuildVersion:	20B28

comment:3 Changed 5 months ago by neilt (Neil Tiffin)

Cc: neilt added

comment:4 Changed 5 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #61235.

Note: See TracTickets for help on using tickets.