#61531 closed defect (fixed)

R @4.0.3 build failed with MacOS BigSur

Reported by: Tommaso93 Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: i0ntempest, Tommaso93
Port: R

Description

Hi, I tried to install the R port with MacOS BigSur and it does not build. Attached you can find the log file.

Best, Tommaso

Attachments (2)

main.log (156.7 KB) - added by Tommaso93 23 months ago.
config.log (23.9 KB) - added by Tommaso93 23 months ago.

Download all attachments as: .zip

Change History (14)

Changed 23 months ago by Tommaso93

Attachment: main.log added

comment:1 Changed 23 months ago by Tommaso93

Cc: Tommaso93 added

comment:2 Changed 23 months ago by ryandesign (Ryan Schmidt)

Please attach this file as well:

:error:configure Failed to configure R, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_R/R/work/R-4.0.3/config.log

comment:3 Changed 23 months ago by i0ntempest

Probably caused by the compiler not understanding deployment target 11.0. But yea please add config.log.

Last edited 23 months ago by i0ntempest (previous) (diff)

comment:4 Changed 23 months ago by mf2k (Frank Schima)

Cc: i0ntempest added; kjell.konis@… szf1234@… removed
Owner: set to kjellpk
Status: newassigned

comment:5 Changed 23 months ago by thermalecology

Yep,

clang: error: invalid version number in 'MACOSX_DEPLOYMENT_TARGET=11.0'

comment:6 Changed 23 months ago by Tommaso93

Yes, sorry. I have attached the config.log file.

Changed 23 months ago by Tommaso93

Attachment: config.log added

comment:7 Changed 23 months ago by i0ntempest

In that case add macosx_deployment_target 10.16 in the portfile to temporarily get around this. Completely fixing this probably requires an update of clang compiler.

comment:8 Changed 23 months ago by thermalecology

You can add this, but then you will get "clang: error: invalid version number in '-mmacosx-version-min=11.0'" when you try to compile a package.

comment:10 Changed 23 months ago by i0ntempest

That’s a change of ccache port made 4 years ago?

comment:12 Changed 23 months ago by cjones051073 (Chris Jones)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.