Opened 2 months ago

Last modified 2 months ago

#61638 assigned defect

dbus: Could not find domain for

Reported by: Martin-Fox Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: mojave Cc:
Port: dbus

Description (last modified by ryandesign (Ryan Schmidt))

--->  Some of the ports you installed have notes:
  dbus has the following notes:
    Startup items (named 'dbus-system, dbus-session') have been generated that will aid in starting dbus with launchd. They are disabled by default. Execute the following command to start them, and to cause them to launch at startup:

        sudo port load dbus
bash-3.2$ sudo port load dbus
Password:
--->  Loading startupitem 'dbus-system' for dbus
--->  Loading startupitem 'dbus-session' for dbus
Error: Failed to load dbus: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_dbus/dbus/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port dbus failed
bash-3.2$ cat  /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_dbus/dbus/main.log
version:1
:debug:sysinfo macOS 10.14 (darwin/18.2.0) arch i386
:debug:sysinfo MacPorts 2.6.4
:debug:sysinfo Xcode 10.1
:debug:sysinfo SDK 10.14
:debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 10.14
:debug:main Executing org.macports.main (dbus)
:debug:load load phase started at Tue Nov 24 12:24:44 CET 2020
:debug:load Executing org.macports.load (dbus)
:notice:load --->  Loading startupitem 'dbus-system' for dbus
:debug:load system: /bin/launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
:notice:load --->  Loading startupitem 'dbus-session' for dbus
:debug:load dropping privileges: euid changed to 501, egid changed to 20.
:debug:load system: /bin/launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
:info:load Could not find domain for
:info:load Command failed: /bin/launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
:info:load Exit code: 112
:debug:load elevating privileges for exec_as_uid: euid changed to 0, egid changed to 0.
:error:load Failed to load dbus: command execution failed
:debug:load Error code: NONE
:debug:load Backtrace: command execution failed
:debug:load     while executing
:debug:load "exec_as_uid $uid {system "$launchctl_path load -w $path"}"
:debug:load     ("uplevel" body line 34)
:debug:load     invoked from within
:debug:load "uplevel 1 $body"
:debug:load     (procedure "portstartupitem::foreach_startupitem" line 43)
:debug:load     invoked from within
:debug:load "portstartupitem::foreach_startupitem {
:debug:load         if {(![info exists ::portstartupitem::load_only] || $si_name in ${::portstartupitem::load_only})
:debug:load       ..."
:debug:load     (procedure "portload::load_main" line 5)
:debug:load     invoked from within
:debug:load "$procedure $targetname"
:error:load See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_dbus/dbus/main.log for details.
bash-3.2$

Change History (1)

comment:1 Changed 2 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: mojave added
Owner: set to MarcusCalhoun-Lopez
Port: dbus added
Status: newassigned
Summary: Failed to load dbus: command execution faileddbus: Could not find domain for
Version: 2.6.4

Searching for this error, I found https://github.com/buildkite/docs/issues/353, where someone said that this could happen if you are trying to do this over an ssh connection to a Mac that isn't logged in to a GUI session. If that's the case, log in to a GUI session first.

Last edited 2 months ago by ryandesign (Ryan Schmidt) (previous) (diff)
Note: See TracTickets for help on using tickets.