Opened 5 months ago

Closed 8 days ago

Last modified 8 days ago

#61639 closed defect (fixed)

iverilog @10.3_0 fails to build when bison port is installed

Reported by: mtetcs Owned by: padf
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: iverilog

Description

:info:build parse.cc:299:10: fatal error: 'parse.hh' file not found
:info:build #include "parse.hh"
:info:build          ^~~~~~~~~~
:info:build 1 warning and 1 error generated.
:info:build make[1]: *** [parse.o] Error 1

Attachments (1)

main.log (90.1 KB) - added by mtetcs 5 months ago.
main.log

Download all attachments as: .zip

Change History (9)

Changed 5 months ago by mtetcs

Attachment: main.log added

main.log

comment:1 Changed 5 months ago by mf2k (Frank Schima)

Cc: paf@… removed
Owner: set to padf
Status: newassigned

comment:2 Changed 5 months ago by mtetcs

Note that the current source code direct from the repo compiles correctly:

Icarus Verilog version 12.0 (devel) (s20150603-992-g8da8261f)

https://github.com/steveicarus/iverilog

comment:3 Changed 8 days ago by ryandesign (Ryan Schmidt)

Keywords: bigsur added

We are not able to reproduce this issue. We have iverilog 10.3 built successfully on our macOS 11 build machines.

It looks like it could be bison related. Maybe it works with macOS bison but not MacPorts bison or vice versa. Do you have the MacPorts bison port installed? If so, try uninstalling it. If not, try installing it.

comment:4 Changed 8 days ago by ryandesign (Ryan Schmidt)

Keywords: bigsur removed
Summary: iverilog @10.3_0 fails to build on Big Suriverilog @10.3_0 fails to build when bison port is installed

In fact I am able to reproduce the issue when the MacPorts bison port is installed and deactivating that port allows the build to succeed.

Here is the commit where upstream fixed it: https://github.com/steveicarus/iverilog/commit/5b699c1be73e789831db01e779a41478c0c62309

comment:5 Changed 8 days ago by ryandesign (Ryan Schmidt)

That commit is included in stable version 11.0, so the port should be updated to the latest stable version to fix this.

comment:6 Changed 8 days ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

In 999d3579c67d9b2c89d931e2b751bb1e17bb3ee7/macports-ports (master):

iverilog: Fix build with MacPorts bison installed

Closes: #61639

comment:7 Changed 8 days ago by ryandesign (Ryan Schmidt)

I went ahead and committed just that fix since it's an easy patch and I don't know how difficult updating to version 11 is. I filed #62670 for the update to version 11.

I verified that it now builds with both macOS bison and MacPorts bison.

comment:8 Changed 8 days ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added
Note: See TracTickets for help on using tickets.