Opened 14 months ago

Closed 13 months ago

Last modified 13 months ago

#61640 closed defect (duplicate)

mpich-default @3.3.2 build error: Undefined symbols for architecture x86_64

Reported by: ccottap (Carlos Cotta) Owned by: eborisch (Eric A. Borisch)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: neilt (Neil Tiffin), dliessi (Davide Liessi)
Port: mpich-default

Description

Trying to build mpich-default on macOS 11.0.1, Xcode CLT 12.2.0.0.1.160407682. The build fails during the linking phase, producing a long list of errors:

:info:build Undefined symbols for architecture x86_64:
:info:build   "_ADIOI_Datarep_head", referenced from:
:info:build       _PMPI_Register_datarep in libpromio.a(libpromio_la-register_datarep.o)
:info:build   "_ADIOI_Datatype_iscontig", referenced from:
:info:build       _MPIOI_File_iread in libpromio.a(libpromio_la-iread.o)
:info:build       _PMPI_File_iread_shared in libpromio.a(libpromio_la-iread_sh.o)
:info:build       _MPIOI_File_iwrite in libpromio.a(libpromio_la-iwrite.o)
:info:build       _PMPI_File_iwrite_shared in libpromio.a(libpromio_la-iwrite_sh.o)
:info:build       _MPIOI_File_read in libpromio.a(libpromio_la-read.o)
:info:build       _PMPI_File_read_shared in libpromio.a(libpromio_la-read_sh.o)
:info:build       _MPIOI_File_write in libpromio.a(libpromio_la-write.o)
:info:build       ...
.
.
.
:info:build   "_MPI_Win_unlock", referenced from:
:info:build       _PMPIX_Mutex_lock in lib_libpmpi_la-mutex_lock.o
:info:build       _PMPIX_Mutex_unlock in lib_libpmpi_la-mutex_unlock.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build collect2: error: ld returned 1 exit status

(list of errors truncated due to excessive length - please, see attached log).

Attachments (1)

main.log.zip (217.6 KB) - added by ccottap (Carlos Cotta) 14 months ago.
mpich-default 3.3.2 build log (20201124)

Download all attachments as: .zip

Change History (7)

Changed 14 months ago by ccottap (Carlos Cotta)

Attachment: main.log.zip added

mpich-default 3.3.2 build log (20201124)

comment:1 Changed 14 months ago by ccottap (Carlos Cotta)

Owner: changed from eborisch to ccottap

It looks like #61637 reports the same problem, which may be in turn caused by #61584.

comment:2 Changed 14 months ago by ccottap (Carlos Cotta)

Owner: changed from ccottap to eborisch

comment:3 Changed 14 months ago by ccottap (Carlos Cotta)

Following #61584, I added

macosx_deployment_target 10.16

to macports.conf and mpich-default could be successfully built.

comment:4 Changed 13 months ago by neilt (Neil Tiffin)

Cc: neilt added

comment:5 Changed 13 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: assignedclosed

comment:6 Changed 13 months ago by dliessi (Davide Liessi)

Cc: dliessi added
Note: See TracTickets for help on using tickets.