#61687 closed defect (duplicate)

samba3 @3.6.25_3: build failure (gettimeofday)

Reported by: eschnett (Erik Schnetter) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: samba3

Description

Building "samba3" on Big Sur fails for me. The relevant lines of the log file are:

:info:build ../lib/util/time.c:56:19: error: too few arguments to function call, expected 2, have 1
:info:build         gettimeofday(tval);
:info:build         ~~~~~~~~~~~~     ^
:info:build /Library/Developer/CommandLineTools/SDKs/MacOSX11.0.sdk/usr/include/sys/time.h:197:1: note: 'gettimeofday' declared here
:info:build int     gettimeofday(struct timeval * __restrict, void * __restrict);
:info:build ^

This is likely caused by a problem in the configure state earlier:

:info:configure checking if gettimeofday takes TZ argument... no

Attachments (1)

main.log (317.2 KB) - added by eschnett (Erik Schnetter) 11 months ago.
Build log

Download all attachments as: .zip

Change History (3)

Changed 11 months ago by eschnett (Erik Schnetter)

Attachment: main.log added

Build log

comment:1 Changed 11 months ago by kencu (Ken)

looks much like #61454

comment:2 Changed 11 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.