Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#61704 closed defect (duplicate)

icu Failed to destroot. file already exists!

Reported by: julesberry Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: icu

Description

Using one of those new ARM chip MacBookPros, 13 inch. Macports v2.6.4

Trying to install R. Failed at installing icu (also tried icu +universal which results in same error). Tried cleaning everything, but same thing happens each time...

Error: Failed to destroot icu: error copying "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_icu/icu/work/destroot-x86_64//Developer" to "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_icu/icu/work/destroot-intel/Developer": file already exists
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_icu/icu/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port icu failed

Change History (2)

comment:1 Changed 11 months ago by jmroot (Joshua Root)

Keywords: destroot R icu ARM removed
Resolution: duplicate
Status: newclosed

I believe this would only happen on subsequent attempts after an initial failed +universal build, and if you clean icu first you will see the initial failure is the same as #45268.

comment:2 Changed 11 months ago by julesberry

Thanks. I searched up through my terminal and see you are right. The very first run through, it was a "cannot be merged" message. Since then I successfully installed texlive which also installs icu, and it seems to have done it without a problem, so I am hoping that R may install correctly next time I try... :o

Note: See TracTickets for help on using tickets.