#61756 closed defect (duplicate)

Apache php8 module looking for argon2 library in /usr/lib due to wrong rpath

Reported by: jrcii (John Cornell) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: argon2

Description (last modified by jrcii (John Cornell))

Expected: start apache successfully with mod_php80 in httpd.conf

Observed: apache says that mod_php80 is trying to load @rpath/libargon2.1.dylib and can't find the image

Steps to reproduce: install apache2, php80, and php80-apache2handler, and try /opt/local/sbin/httpd -k start

Temporary Fix: sudo install_name_tool -add_rpath /opt/local/lib /opt/local/lib/apache2/modules/mod_php80.so

I'm reciting these errors, paths, and filenames from memory so sorry if they're a bit off.

Change History (4)

comment:1 Changed 11 months ago by jrcii (John Cornell)

Description: modified (diff)

comment:2 Changed 11 months ago by jrcii (John Cornell)

Description: modified (diff)

comment:3 Changed 11 months ago by kencu (Ken)

see <https://github.com/macports/macports-ports/pull/9331> for the fix, we are just waiting for the maintainer to commit or time out.

comment:4 Changed 11 months ago by kencu (Ken)

Keywords: php apache2 httpd removed
Port: argon2 added; php80-apache2handler removed
Resolution: duplicate
Status: newclosed

thank you very much for the report. This turns out to be a duplicate of another ticket, so we'll follow it along there.

#61735

as mentioned, the fix is already in the PR queue

Note: See TracTickets for help on using tickets.