Opened 7 weeks ago

Last modified 3 days ago

#61772 reopened defect

owncloud-client @ 2.7.2: CMake Error: Could not find a configuration file for package "Qt5" that is compatible

Reported by: thetrial (alabay) Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: elcapitan Cc:
Port: owncloud-client

Description

Maybe just a little problem (I’d hope so):

:info:configure CMake Error at src/CMakeLists.txt:1 (find_package):
:info:configure   Could not find a configuration file for package "Qt5" that is compatible
:info:configure   with requested version "5.12".
:info:configure   The following configuration files were considered but not accepted:
:info:configure     /opt/local/lib/cmake/Qt5/Qt5Config.cmake, version: 5.11.3
:info:configure -- Configuring incomplete, errors occurred!

Under macOS 10.11 Qt 5 is the possible maximum.

Change History (28)

comment:1 Changed 7 weeks ago by mf2k (Frank Schima)

Keywords: legacy-os removed

comment:2 Changed 7 weeks ago by Schamschula (Marius Schamschula)

According to the upstream developer website owncloud-client is not compatible with macOS El Capitan. The minimum OS is Sierra. I will note this in the Portfile.

Last edited 7 weeks ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:3 Changed 7 weeks ago by Schamschula (Marius Schamschula)

It also looks like the minimum version of Qt5 has been raised to 5.13.

Last edited 7 weeks ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:4 Changed 7 weeks ago by Schamschula (Marius Schamschula)

The best way to deal with older OS versions it to lock in an older version of own cloud-client.

comment:5 Changed 7 weeks ago by Schamschula (Marius Schamschula)

Resolution: fixed
Status: assignedclosed

In f5cc63bd1e079447089e9f6797ecf0ec36f4a808/macports-ports (master):

owncloud-client: lock in 2.6.3 for El Capitan and below

Closes: #61772

comment:6 Changed 7 weeks ago by thetrial (alabay)

I guess minimum OS is Sierra only because of Qt6. This has been since 2.3 or 2.4. But I built all recent versions perfectly with Qt5. This is possible due to Macports than links from Qt6 to Qt5. The same happens in Wireshark. So I guess, if Qt5 works (und until now it worked) this could be fixed without problem – and the new version would work with El Capitan like 2.6 does. This should not be locked otherwise.

comment:7 Changed 7 weeks ago by thetrial (alabay)

Resolution: fixed
Status: closedreopened

comment:8 Changed 7 weeks ago by Schamschula (Marius Schamschula)

Unfortunately, I can't test older macOS versions locally. As the owncloud website does not specify the reason for the minimum supported OS, I have to be conservative.

comment:9 Changed 7 weeks ago by Schamschula (Marius Schamschula)

If you can get it to work, by all means submit a PR.

comment:10 in reply to:  5 ; Changed 7 weeks ago by ryandesign (Ryan Schmidt)

Replying to thetrial:

I guess minimum OS is Sierra only because of Qt6. This has been since 2.3 or 2.4. But I built all recent versions perfectly with Qt5. This is possible due to Macports than links from Qt6 to Qt5. The same happens in Wireshark. So I guess, if Qt5 works (und until now it worked) this could be fixed without problem – and the new version would work with El Capitan like 2.6 does. This should not be locked otherwise.

Qt 6 has not been released yet and is not in MacPorts yet.

Replying to Schamschula:

In f5cc63bd1e079447089e9f6797ecf0ec36f4a808/macports-ports (master):

owncloud-client: lock in 2.6.3 for El Capitan and below

Closes: #61772

You don't appear to have defined a way for earlier systems to download the distfile.

--->  Fetching distfiles for owncloud-client
DEBUG: elevating privileges for fetch: euid changed to 0, egid changed to 0.
DEBUG: dropping privileges: euid changed to 502, egid changed to 501.
DEBUG: Executing proc-pre-org.macports.fetch-fetch-0
DEBUG: Executing org.macports.fetch (owncloud-client)
--->  owncloud-client-2.6.3.tar.gz does not exist in /opt/local/var/macports/distfiles/owncloud-client

Also, don't forget to check that ${os.platform} eq "darwin" before you check what ${os.major} is.

comment:11 in reply to:  10 Changed 7 weeks ago by thetrial (alabay)

Replying to ryandesign:

Replying to thetrial:

I guess minimum OS is Sierra only because of Qt6. This has been since 2.3 or 2.4. But I built all recent versions perfectly with Qt5. This is possible due to Macports than links from Qt6 to Qt5. The same happens in Wireshark. So I guess, if Qt5 works (und until now it worked) this could be fixed without problem – and the new version would work with El Capitan like 2.6 does. This should not be locked otherwise.

Qt 6 has not been released yet and is not in MacPorts yet.

I don’t know if Qt6 would work with El Capitan. But Qt5 does. I meant: Software that is usually using Qt6, has the possibility in Macports to use Qt5. And that makes them compatible with El Capitan. So are my observations. Under normal circumstances OwnCloud 2.6.3 would not work with El Capitan either. Prebuilt, it uses Qt6. But in Macports it’s been built with Qt5. So why should that not work with the next versions?

comment:12 Changed 7 weeks ago by thetrial (alabay)

So this is dead now? Or is there a way to link that to Qt5 as it was before? I don’t understand what the problem was that broke the build.

comment:13 in reply to:  10 Changed 7 weeks ago by Schamschula (Marius Schamschula)

Fixed the download issue for the locked in version for older macOS versions.

Added os.platform test to wrap around os.major tests.

There are no changes to the qt5 requirements.

See: https://github.com/macports/macports-ports/commit/0d22fe850f3a5fdad39a82b12ed6db42c296ea12

Last edited 7 weeks ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:14 Changed 7 weeks ago by thetrial (alabay)

But there is no 2.7 for El Capitan now shown? Why? 2.6 was initially also not for El Capitan (precompiled) but one could build ist. What is now different in 2.7?

comment:15 Changed 6 weeks ago by thetrial (alabay)

This is what I always get, when building with the given Qt5 instead of Qt6 (that is not für El Capitan):

Warning: Qt dependency is not the latest version but may be the latest supported on your OS

So, it should work. If.

comment:16 Changed 6 weeks ago by Schamschula (Marius Schamschula)

If?

Does it build and work?

As I commented above, I don't have access to macOS versions older than Mojave to test on, other than throwing changes at CI and the MacPorts build bots. I would prefer to have verification if a change regarding older OSs works before committing to Github.

comment:17 Changed 6 weeks ago by thetrial (alabay)

I filed a problem. After that this port was cut from my El Capitan. There was an issue with Qt … it asked for 5.12 instead of 5.11? I’m not so deep in it to judge what that means. Why is there a Qt here? As depency, I guess. So I would have awaited, that it gets updated automatically. If I’d know how to deal with these things I’d fix it. But … it seems I’m the only one on the world with 10.11 and the wish to use the client from MacPorts. The prebuilt binary would not run since years, with MacPorts’ version it ran. I cannot gage what is the problem now.

Last edited 6 weeks ago by thetrial (alabay) (previous) (diff)

comment:18 Changed 6 weeks ago by kencu (Ken)

You could stick with an older version of owncloud forever if that suits you, or -- you can look into, or ask someone to look into, what might be done to try to keep the current version working on 10.11, if possible.

This might be your project! It is not that hard to learn what to do, and it's how most of us got started in doing this in the first place. It's not without any effort that I made clang-9.0 work on 10.5 Leopard, for example.

ie: what exactly changed in the code to make owncloud not work on 10.11? Is it possible to work around this?

comment:19 Changed 6 weeks ago by Schamschula (Marius Schamschula)

thetrial: Qt is the graphical interface used by own cloud-client. The App cannot be built without it. According to the qt5 Portfile, the minimum macOS version for the current version of qt5 is Sierra. Indeed, there are only prebuilt packages for qt5.12.4 and above available for Sierra and up in the packages archive. Unless you can find or build a version of qt5 the works with El Capitan, there is no point building owncloud-client. It may be possible to build an older release of qt5. It looks like qt5.11.3 was the last version to support El Capitan.

See: https://github.com/macports/macports-ports/commit/e0babf1f7ad4f6675b3a8ec2c8a105a4af675427#diff-bc9f30dc8c9f361f400189b91801321d634f45c504735b63dd156a06e245449f

kencu: As I noted above, I use the minimum macOS version from the upstream documentation.

comment:20 Changed 6 weeks ago by thetrial (alabay)

Yes, Qt 5.11.3 is built and ready here. So if the dependency to Qt 5.12 is not absolutely necessary and you could link that back to Qt 5.11 – then, I think, I could build and get the client 2.7 to work under macOS 10.11. Irrespective of the OC youngsters’ documented minimum OS. Because, consider I also built client 2.6.3, that is not officially supported with macOS 10.11. The point is Qt and the declared dependency in owncloud-client, IMHO.

comment:21 Changed 6 weeks ago by kencu (Ken)

here's an example of what you would have to do. I looked through the octave source code, and worked around the qt5 only parts to re-enable building octave with qt4. This was an easy one... who knows what owncloud might need:

<https://github.com/macports/macports-ports/pull/9355/commits/1730fe5f9b9fe222426f3bae1eb16ed2b31b303f#diff-39856c5cb2945bf4c74135cf064f95a4decb7c4fb43bc965b4e9a932c5a5948f>

comment:22 Changed 3 days ago by thetrial (alabay)

If wireshark 3.4 with qt is portable with a qt 5 instead 6 version¹ … could this be a torch for further adaptations of owncloud-clients? Then older OS could use newer clients and maybe later on the infinite scale technology.

¹ https://trac.macports.org/ticket/61511

comment:23 Changed 3 days ago by Schamschula (Marius Schamschula)

I don't understand this Qt6 business. Owncloud-client currently uses Qt5.

The issue here is that the upstream developer clearly states that they don't support older macOS versions. We have to work around any backward incompatible changes to make owncloud-client build on older macOS versions.

comment:24 Changed 3 days ago by thetrial (alabay)

Ah, I thought it uses Qt6. If you could link ist to the last used Qt5 under el capitan, it would work. The developer state something, but fight obsolescence! They are ignorant and not interested, maybe too young for older machines. Is 2.6.3 supported by el capitan? No. Bu? compiled here, from Macports, it works. It’s (yet) only and only an issue of the Qt-version.

comment:25 Changed 3 days ago by Schamschula (Marius Schamschula)

Yes, 2.6.3 should work for older macOS versions.

I'll look to push a Portfile with version 2.6.3 for older OSs this afternoon.

comment:26 Changed 3 days ago by Schamschula (Marius Schamschula)

Wait! It's already in the Portfile that way.

comment:27 Changed 3 days ago by thetrial (alabay)

I know it is, I had built it.

Why don’t you try it with later versions, too? Is so much changed except the Qt-dependency? Maybe they would also work if fixated to the appropiate Qt5.

comment:28 Changed 3 days ago by Schamschula (Marius Schamschula)

How?

I don't have any machines running very old macOS versions (other than unpowwered, stored in the closet), and don't have time maintain a fleet of virtual machines. I'm much more concerned in getting it running on my Apple SoC Mac mini. Currently qt5-qtwebkit is a blocker.

Regressing older macOS versions to 2.6.3 didn't require any testing, as everything built before.

Note: See TracTickets for help on using tickets.