Opened 15 years ago

Closed 15 years ago

#6178 closed defect (invalid)

install hangs after download

Reported by: txa@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc:
Port:

Description

I have got a new imac and installed xcode and darwinports. I have also done the selfupdate -d and this worked fine. However, whenever I try to install a package the first file is downloaded and then the installer gets stuck.

thorsten-altenkirchs-imac-g5:~ txa$ sudo port -vf install ghc Password: ---> Fetching gmp ---> gmp-4.1.4.tar.bz2 doesn't seem to exist in /opt/local/var/db/dports/distfiles/gmp ---> Attempting to fetch gmp-4.1.4.tar.bz2 from ftp://ftp.gnu.org/gnu/gmp

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 1641k 100 1641k 0 0 9216 0 0:03:02 0:03:02 --:--:-- 0

The same happens with every module I tried and with or without -f. I have also tried dp 1.1 and 1.2 and have uninstalled and reinstalled xcode.

I am sorry, if this is something obvious (I am new to MacOS and darwinports) but I have no idea what to do.

Any help is appreciated. Thorsten

Change History (2)

comment:1 Changed 15 years ago by blb@…

Since it's having trouble via ftp, my first question is whether you have installed the 2005-009 security update as that happens to fix an issue which manifests itself as what you are seeing?

comment:2 Changed 15 years ago by yeled@…

Resolution: invalid
Status: newclosed

this is without a doubt the security update issue.

once updated you will find that curl will complete your downloads.

(hint: open "Software Update" Prefrence Pane and go from there)

Note: See TracTickets for help on using tickets.