New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #6183 (closed defect: invalid)

Opened 8 years ago

Last modified 8 years ago

BUG: Gnome doesn't work

Reported by: m.rick@… Owned by: gnome-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

I have intalled all the libraries for Gnome but nothing works !

When i start gnome-session, it doesn't sho me the gnome startup screen, doesn't launch gnome-panels, doesn't start nautilus ....

In fullscreen mode I get this :

"There was an error while lauching the GNOME Preferences deamon.

Some of the functionalities, like themes, sounds or desktop pictures mayn't work correctly.

The Preferences deamon started to much times.

The last error message was : Activation of « OAFIID:GNOME_SettingsDeamon » failed.

Gnome will try to restart the Preferences deamon the next you will connect."

And now I get this ..... :

aymeric$ /opt/local/bin/gnome-session

(gnome-session:17334): WARNING : Unable to read ICE authority file:

/Users/aymeric/.ICEauthority

imac-g5-de-aymeric-gillaizeau:~ aymeric$

If i do all of this with xterm, the applications menu is empty, no settings, nothing and no icons, while all the themes have been installed ...

All the screenshots :

http://img472.imageshack.us/img472/818/image16op.png http://img386.imageshack.us/img386/9384/image72yf.png http://img472.imageshack.us/img472/6259/image38ue.png http://img472.imageshack.us/img472/2589/image46ld.png http://img386.imageshack.us/img386/1990/image60ue.png http://img472.imageshack.us/img472/9040/image51xy.png

All this time to try to install everything for nothing ... :-(

Attachments

gnome-session.crash.log (30.0 KB) - added by m.rick@… 8 years ago.
Gnome Session Crash Log
gnome-vfs-daemon.crash.log (36.7 KB) - added by m.rick@… 8 years ago.
Gnome VFS Daemon Crash Log
nautilus.crash.log (1.4 KB) - added by m.rick@… 8 years ago.
Nautilus Crash Log
nautilus-file-management-properties.crash.log (8.2 KB) - added by m.rick@… 8 years ago.
Nautilus File Manager Crash Log
gedit.crash.log (8.3 KB) - added by m.rick@… 8 years ago.
Gedit Crash Log

Change History

Changed 8 years ago by m.rick@…

Gnome Session Crash Log

Changed 8 years ago by m.rick@…

Gnome VFS Daemon Crash Log

Changed 8 years ago by m.rick@…

Nautilus Crash Log

Changed 8 years ago by m.rick@…

Nautilus File Manager Crash Log

Changed 8 years ago by m.rick@…

Gedit Crash Log

comment:1 Changed 8 years ago by rhwood@…

Looking at the Gnome Session and Gnome VFS Daemon Crash Logs, I see that those are trying to launch from /sw/bin, indicating that those two programs were installed by Fink. I think that there might be a conflict between things installed by Fink and things installed by DarwinPorts, especially since the upstream versions of the GNOME packages used by Fink are about 2 years older than those used by DarwinPorts. My guess is that the two package management systems are conflicting.

comment:2 Changed 8 years ago by mww@…

  • Summary changed from Gnome doesn't work to BUG: Gnome doesn't work

comment:3 Changed 8 years ago by m.rick@…

(In reply to comment #6)

Looking at the Gnome Session and Gnome VFS Daemon Crash Logs, I see that those

are trying to launch

from /sw/bin, indicating that those two programs were installed by Fink. I

think that there might be a

conflict between things installed by Fink and things installed by DarwinPorts,

especially since the upstream

versions of the GNOME packages used by Fink are about 2 years older than those

used by DarwinPorts. My

guess is that the two package management systems are conflicting.

But if i remove Fink or use the darwin ports packages to another parition without fink, it doesn't work anyway, iahve exactly the same bugs. And it should conflit with Fink since the 2 systems have been done to be independant.

comment:4 Changed 8 years ago by rhwood@…

I have just completed a clean install of gnome-desktop-suite on a clean mac (10.4.4 w/xcode 2.2) and the gnome desktop runs correctly. I even went so far as to create a new user account, copying my .profile and .xinitrc to that user account, and running X11 under that user. I got one error about a mixer applet, deleted it from the panel, and then it all ran without error. The only problems I am having now is that my X11 display is for some reason shifted to the left on screen with this test case user account.

Here is the list of files or directories created when GNOME ran: .Xauthority .esd_auth .fonts.cache-1 .gconf .gconfd .gnome .gnome2 .gnome2_private .gtkrc-1.2-gnome2 .nautilus

comment:5 Changed 8 years ago by rhwood@…

Further test case use reveals that for some reason, the panels are not drawing anything if set to "expand" in the panel preferences.

comment:6 Changed 8 years ago by markd@…

Randall -can this bug be closed?

comment:7 Changed 8 years ago by rhwood@…

  • Status changed from new to closed
  • Resolution set to invalid

Closing bug as it is too nebulous to provide for meaningful action.

Note: See TracTickets for help on using tickets.