Opened 5 months ago

Closed 4 months ago

#61885 closed defect (duplicate)

cotvnc @2.2b2_1: error: unable to spawn process (No such file or directory)

Reported by: vgrebenschikov Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: mojave catalina bigsur Cc:
Port: cotvnc

Description

$ sudo port install cotvnc
Password:
--->  Computing dependencies for cotvnc
--->  Fetching archive for cotvnc
--->  Attempting to fetch cotvnc-2.2b2_1.darwin_19.x86_64.tbz2 from https://packages.macports.org/cotvnc
--->  Attempting to fetch cotvnc-2.2b2_1.darwin_19.x86_64.tbz2 from https://lil.fr.packages.macports.org/cotvnc
--->  Attempting to fetch cotvnc-2.2b2_1.darwin_19.x86_64.tbz2 from https://cph.dk.packages.macports.org/cotvnc
--->  Fetching distfiles for cotvnc
--->  Verifying checksums for cotvnc
--->  Extracting cotvnc
--->  Applying patches to cotvnc
--->  Configuring cotvnc
--->  Building cotvnc
Error: Failed to build cotvnc: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port cotvnc failed

Details:

# tail -n20 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/main.log
:info:build error: unable to spawn process (No such file or directory) (in target 'Chicken' from project 'Chicken')
:info:build ** BUILD FAILED **
:info:build The following build commands failed:
:info:build 	Nasm /jisseflt.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jisseflt.asm
:info:build 	Nasm /jiss2red.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2red.asm
:info:build 	Nasm /jsimdcpu.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jsimdcpu.asm
:info:build 	Nasm /jiss2fst.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2fst.asm
:info:build 	Nasm /jiss2int.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2int.asm
:info:build 	Nasm /jiss2flt.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2flt.asm
:info:build 	Nasm /jimmxred.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jimmxred.asm
:info:build 	Nasm /jimmxint.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jimmxint.asm
:info:build (8 failures)
:info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc" && /usr/bin/xcodebuild  -alltargets -configuration Deployment build INSTALL_PATH=/Applications/MacPorts  OBJROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/" SYMROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/" MACOSX_DEPLOYMENT_TARGET=10.15 ARCHS=x86_64 SDKROOT="/Applications/Development/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++"
:info:build Exit code: 65
:error:build Failed to build cotvnc: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/main.log for details.

Notice strange attempt to place object files into root directory while build:

# cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc" && /usr/bin/xcodebuild -alltargets -configuration Deployment build INSTALL_PATH=/Applications/MacPorts OBJROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/" SYMROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/" MACOSX_DEPLOYMENT_TARGET=10.15 ARCHS=x86_64 SDKROOT="/Applications/Development/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++"
...
Nasm /jsimdcpu.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jsimdcpu.asm (in target 'Chicken' from project 'Chicken')
    cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc
    /Applications/Development/Xcode.app/Contents/Developer/usr/bin/nasm /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jsimdcpu.asm -fmacho -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/Deployment/include -I/opt/local/include -I /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/ -o /jsimdcpu.o
error: unable to spawn process (No such file or directory) (in target 'Chicken' from project 'Chicken')

Nasm /jisseflt.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jisseflt.asm (in target 'Chicken' from project 'Chicken')
    cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc
    /Applications/Development/Xcode.app/Contents/Developer/usr/bin/nasm /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jisseflt.asm -fmacho -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/Deployment/include -I/opt/local/include -I /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/ -o /jisseflt.o
error: unable to spawn process (No such file or directory) (in target 'Chicken' from project 'Chicken')

Nasm /jiss2red.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2red.asm (in target 'Chicken' from project 'Chicken')
    cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc
    /Applications/Development/Xcode.app/Contents/Developer/usr/bin/nasm /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2red.asm -fmacho -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/build/Deployment/include -I/opt/local/include -I /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/ -o /jiss2red.o
error: unable to spawn process (No such file or directory) (in target 'Chicken' from project 'Chicken')

** BUILD FAILED **


The following build commands failed:
	Nasm /jsimdcpu.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jsimdcpu.asm
	Nasm /jisseflt.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jisseflt.asm
	Nasm /jiss2red.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_cotvnc/cotvnc/work/trunk/cotvnc/libjpeg-turbo/simd/jiss2red.asm
(3 failures)

Attachments (1)

main.log (161.7 KB) - added by vgrebenschikov 5 months ago.

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by vgrebenschikov

Attachment: main.log added

comment:1 Changed 5 months ago by vgrebenschikov

Summary: cotvnc does not build on 10.15.7cotvnc @2.2b2_1 failed to build on MacOS 10.15.7

comment:2 Changed 4 months ago by ryandesign (Ryan Schmidt)

Keywords: mojave catalina bigsur added
Summary: cotvnc @2.2b2_1 failed to build on MacOS 10.15.7cotvnc @2.2b2_1: error: unable to spawn process (No such file or directory)

We see the same on 10.14: https://build.macports.org/builders/ports-10.14_x86_64-builder/builds/74912/steps/install-port/logs/stdio

But it builds fine for me on 10.13 with Xcode 9.4.1.

Probably an Xcode 10-and-later issue. Maybe the well-known derived data path issue.

Last edited 4 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 Changed 4 months ago by kencu (Ken)

duplicate of #57174

comment:4 Changed 4 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.