Opened 2 months ago

Last modified 7 weeks ago

#61934 reopened defect

gnuradio @3.8.2.0_2+docs+... Configure error - build failure

Reported by: xhale (Alex Heyes) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: ra1nb0w
Port: gnuradio

Description

Error: Failed to configure gnuradio: configure failure: command execution failed

Attachments (2)

gnuradio-main.log (531.8 KB) - added by xhale (Alex Heyes) 2 months ago.
main.log
gunradio-main-20201230T1600.log (3.9 MB) - added by xhale (Alex Heyes) 2 months ago.
Attempt 20201231 at 1600 UTC

Change History (32)

Changed 2 months ago by xhale (Alex Heyes)

Attachment: gnuradio-main.log added

main.log

comment:1 Changed 2 months ago by ra1nb0w

michaelld, you tu revbump gobject-introspection and dependencies. In the meantime xhale updates ports and rebuilt gobject with

sudo port -sn upgrade --force gobject-introspection gdk-pixbuf2

then install gnuradio.

Last edited 2 months ago by ra1nb0w (previous) (diff)

comment:2 Changed 2 months ago by ra1nb0w

You can now update ports (sudo port upgrade outdated and everything should work fine.

comment:3 Changed 2 months ago by michaelld (Michael Dickens)

Thank you @ra1nb0w for getting the GR dependency fixed! I really should rev-bump all the other ports that depend on GO-I ...

comment:4 Changed 2 months ago by ra1nb0w

Since, I was not sure which ports are I didn't do that.

Changed 2 months ago by xhale (Alex Heyes)

Attempt 20201231 at 1600 UTC

comment:5 Changed 2 months ago by xhale (Alex Heyes)

Sadly this is still failing for me, seems to be related to gnuradio-companion

:info:configure --   Dependency MAKO_FOUND = TRUE
:info:configure --   Dependency PYGI_FOUND = TRUE
:info:configure --   Dependency GTK_GI_FOUND = FALSE
:info:configure --   Dependency CAIRO_GI_FOUND = TRUE
:info:configure --   Dependency PANGOCAIRO_GI_FOUND = TRUE
:info:configure --   Dependency NUMPY_FOUND = TRUE
:info:configure CMake Error at cmake/Modules/GrComponent.cmake:75 (message):
:info:configure   user force-enabled gnuradio-companion but configuration checked failed
:info:configure Call Stack (most recent call first):
:info:configure   grc/CMakeLists.txt:95 (GR_REGISTER_COMPONENT)
:info:configure -- Configuring incomplete, errors occurred!

comment:6 Changed 2 months ago by michaelld (Michael Dickens)

What does the following return ... run "/opt/local/bin/python3.7", then do:

>>> import gi
>>> gi.require_version('Gtk', '3.0')
>>> from gi.repository import Gtk

comment:7 Changed 2 months ago by xhale (Alex Heyes)

% /opt/local/bin/python3.7
Python 3.7.9 (default, Nov 15 2020, 00:39:33)
[Clang 12.0.0 (clang-1200.0.32.27)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import gi
>>> gi.require_version('Gtk', '3.0')
>>> from gi.repository import Gtk

** (.:86974): WARNING **: 17:02:05.683: Failed to load shared library 'libatk-1.0.0.dylib' referenced by the typelib: dlopen(libatk-1.0.0.dylib, 9): image not found
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 668, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 638, in _load_backward_compatible
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/importer.py", line 145, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/overrides/__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/overrides/Gtk.py", line 131, in <module>
    class Widget(Gtk.Widget):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 168, in __getattr__
    interfaces = tuple(interface for interface in get_interfaces_for_object(info)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 94, in get_interfaces_for_object
    interfaces.append(getattr(module, name))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 207, in __getattr__
    wrapper = metaclass(name, bases, dict_)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/types.py", line 247, in __init__
    register_interface_info(cls.__info__.get_g_type())
TypeError: must be an interface

comment:8 Changed 2 months ago by michaelld (Michael Dickens)

Thx. Let me verify & then rev-bump the next dependency ... looks like the port atk ...

comment:9 Changed 2 months ago by michaelld (Michael Dickens)

working on this ... will take a bit ... in the meantime, you can do the following to see if it helps:

sudo port -f uninstall atk
sudo port install atk

and then:

sudo port clean gnuradio
sudo port install gnuradio

and maybe that works ...

comment:10 Changed 2 months ago by xhale (Alex Heyes)

Hi Michael, no change unfortunately. Please let me know if you need any more logs or console output.

comment:11 Changed 2 months ago by michaelld (Michael Dickens)

Can you run the commands from https://trac.macports.org/ticket/61934#comment:6 again & report back the results?

comment:12 Changed 2 months ago by michaelld (Michael Dickens)

If those commands do -not- result in an error, then please attach the new GR log file

comment:13 Changed 2 months ago by xhale (Alex Heyes)

Commands rerun, same error results:

% /opt/local/bin/python3.7
Python 3.7.9 (default, Nov 15 2020, 00:39:33)
[Clang 12.0.0 (clang-1200.0.32.27)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import gi
>>> gi.require_version('Gtk', '3.0')
>>> from gi.repository import Gtk

** (.:89945): WARNING **: 20:24:16.557: Failed to load shared library 'libatk-1.0.0.dylib' referenced by the typelib: dlopen(libatk-1.0.0.dylib, 9): image not found
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 668, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 638, in _load_backward_compatible
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/importer.py", line 145, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/overrides/__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/overrides/Gtk.py", line 131, in <module>
    class Widget(Gtk.Widget):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 168, in __getattr__
    interfaces = tuple(interface for interface in get_interfaces_for_object(info)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 94, in get_interfaces_for_object
    interfaces.append(getattr(module, name))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/module.py", line 207, in __getattr__
    wrapper = metaclass(name, bases, dict_)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/gi/types.py", line 247, in __init__
    register_interface_info(cls.__info__.get_g_type())
TypeError: must be an interface

comment:14 Changed 2 months ago by michaelld (Michael Dickens)

What does the following return: grep "shared-library" $(port contents atk | grep "\.gir")

comment:15 Changed 2 months ago by xhale (Alex Heyes)

% grep "shared-library" $(port contents atk | grep "\.gir")
             shared-library="libatk-1.0.0.dylib"

comment:16 Changed 2 months ago by michaelld (Michael Dickens)

grr ... OK well we did some tweaks to the atk portfile that should fix this issue ... so please try sudo port selfupdate or sudo port sync then sudo port upgrade outdated and, assuming that works, then try the grep command just above & if that returns the whole library path (should be shared-library="/opt/local/lib/libatk-1.0.0.dylib"), then try installing gnuradio again.

comment:17 Changed 2 months ago by xhale (Alex Heyes)

Full library path returned for libatk, proceeded to clean then reinstall port gnu radio and now volk is failing with 404's! From volk main.log:

:debug:fetch fetch phase started at Thu Dec 31 07:55:21 GMT 2020
:notice:fetch --->  Fetching distfiles for volk
:debug:fetch Executing org.macports.fetch (volk)
:info:fetch --->  volk-2.4.1.tar.gz does not exist in /opt/local/var/macports/distfiles/volk
:notice:fetch --->  Attempting to fetch volk-2.4.1.tar.gz from https://mse.uk.distfiles.macports.org/volk
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:notice:fetch --->  Attempting to fetch volk-2.4.1.tar.gz from https://lil.fr.distfiles.macports.org/volk
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:notice:fetch --->  Attempting to fetch volk-2.4.1.tar.gz from https://github.com/gnuradio/volk/archive/v2.4.1
:info:fetch --->  cpu_features-a8397ba4591237c17d18e4acc091f5f3ebe7391e.tar.gz does not exist in /opt/local/var/macports/distfiles/volk
:notice:fetch --->  Attempting to fetch cpu_features-a8397ba4591237c17d18e4acc091f5f3ebe7391e.tar.gz from https://mse.uk.distfiles.macports.org/volk
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:notice:fetch --->  Attempting to fetch cpu_features-a8397ba4591237c17d18e4acc091f5f3ebe7391e.tar.gz from https://lil.fr.distfiles.macports.org/volk
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:notice:fetch --->  Attempting to fetch cpu_features-a8397ba4591237c17d18e4acc091f5f3ebe7391e.tar.gz from https://github.com/google/cpu_features/archive/a8397ba4591237c17d18e4acc091f5f3ebe7391e

comment:18 Changed 2 months ago by michaelld (Michael Dickens)

Testing a fix for the Volk issue ... will report back shortly once I've verified & pushed those fixes

comment:19 Changed 2 months ago by michaelld (Michael Dickens)

In bebb730f08d028f34fdcd1d8f36b713a36e4cbef/macports-ports (master):

volk: fix checksums, as if a stealth update

Closes: #61948
Ref: #61934

comment:20 Changed 2 months ago by michaelld (Michael Dickens)

Ok .. Volk fixes pushed ... please update ports on your end & try again

comment:21 Changed 2 months ago by ra1nb0w

Gnuradio failed to build today with Dependency GTK_GI_FOUND = FALSE (maybe atk update?). I needed to sudo port -sn upgrade --force gobject-introspection gdk-pixbuf2 atk then it builds fine.

comment:22 in reply to:  21 Changed 2 months ago by michaelld (Michael Dickens)

Replying to ra1nb0w:

Gnuradio failed to build today with Dependency GTK_GI_FOUND = FALSE (maybe atk update?). I needed to sudo port -sn upgrade --force gobject-introspection gdk-pixbuf2 atk then it builds fine.

Interesting. I think we've rev-bumped all of the GO-I related ports that GRC requires ... so we should be good to go here even without force upgrading from source ... hmmm ... need to try installing from pre-compiled binaries to see if those work.

comment:23 Changed 2 months ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

I'm closing this as fixed, since I'm pretty sure it is. If the exact original issue remains, please reopen and post what you've done & the build logs & the active ports.

comment:24 Changed 2 months ago by xhale (Alex Heyes)

Just to confirm this is now working as of 04 Jan 2021. Another dependency - codec2 - had started to fail, but I decided to wait a few days and try again. Thanks for your help!

comment:25 Changed 2 months ago by michaelld (Michael Dickens)

@xhale : so ... all is working again with respect to the original issue? [codec2 was failing for a couple days, but we got it fixed up pretty quickly as of a couple days ago]

comment:26 Changed 2 months ago by xhale (Alex Heyes)

Yes all is working again

comment:27 Changed 2 months ago by michaelld (Michael Dickens)

Excellent! Thanks for reporting back & good luck with your GR work!

comment:28 Changed 7 weeks ago by NF6X (Mark J. Blair)

Resolution: fixed
Status: closedreopened

As of 2021-01-16, starting from a clean and up-to-date MacPorts installation, I still need to run:

sudo port -sn upgrade --force gobject-introspection gdk-pixbuf2 atk

in order to install gnuradio. I think it's the same issue reported here.

comment:29 Changed 7 weeks ago by michaelld (Michael Dickens)

Interesting. Thanks for the report @NF6X. I need to rebase an update to poppler & once that's done I'll rev-bump gobject-introspection gdk-pixbuf2 and atk. That will trigger a build-bot pre-built binary build, which is where the issue is here I believe & with the updated binaries all should be well again. Let's leave this open until it's truly fixed :)

comment:30 Changed 7 weeks ago by McTrk (Mustafa Kocaturk)

Configure succeeded for gnuradio-next after the following steps:

upgrade -s --force gdk-pixbuf2 atk
load dbus
install gnuradio-next +python38

but build is failing now as follows:

.../gnuradio-runtime/lib/pmt/pmt_serialize.cc:17:10: fatal error: 'endian.h' file not found
:info:build #include <endian.h>
Last edited 7 weeks ago by McTrk (Mustafa Kocaturk) (previous) (diff)
Note: See TracTickets for help on using tickets.