Opened 5 months ago

Closed 5 months ago

#61938 closed defect (duplicate)

w3m @0.5.3-38 build failure on Big Sur on M1 Apple Silicon

Reported by: raw-bin (Robin Randhawa) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: bigsur catalina Cc:
Port: w3m

Description

Hi.

I get the following output on attempting to install neomutt:

> sudo port install neomutt
--->  Computing dependencies for neomutt
The following dependencies will be installed:
 boehmgc
 docbook-xml-4.2
 docbook-xsl-nons
 gpgme
 perl5
 w3m
 xmlcatmgr
Continue? [Y/n]: y
--->  Fetching archive for xmlcatmgr
--->  Attempting to fetch xmlcatmgr-2.2_1.darwin_20.arm64.tbz2 from https://mse.uk.packages.macports.org/xmlcatmgr
--->  Attempting to fetch xmlcatmgr-2.2_1.darwin_20.arm64.tbz2.rmd160 from https://mse.uk.packages.macports.org/xmlcatmgr
--->  Installing xmlcatmgr @2.2_1
--->  Activating xmlcatmgr @2.2_1
--->  Cleaning xmlcatmgr
--->  Fetching archive for docbook-xml-4.2
--->  Attempting to fetch docbook-xml-4.2-5.0_1.darwin_20.noarch.tbz2 from https://mse.uk.packages.macports.org/docbook-xml-4.2
--->  Attempting to fetch docbook-xml-4.2-5.0_1.darwin_20.noarch.tbz2.rmd160 from https://mse.uk.packages.macports.org/docbook-xml-4.2
--->  Installing docbook-xml-4.2 @5.0_1
--->  Activating docbook-xml-4.2 @5.0_1
--->  Cleaning docbook-xml-4.2
--->  Fetching archive for docbook-xsl-nons
--->  Attempting to fetch docbook-xsl-nons-1.79.2_0.darwin_20.noarch.tbz2 from https://mse.uk.packages.macports.org/docbook-xsl-nons
--->  Attempting to fetch docbook-xsl-nons-1.79.2_0.darwin_20.noarch.tbz2.rmd160 from https://mse.uk.packages.macports.org/docbook-xsl-nons
--->  Installing docbook-xsl-nons @1.79.2_0
--->  Activating docbook-xsl-nons @1.79.2_0
--->  Cleaning docbook-xsl-nons
--->  Fetching archive for gpgme
--->  Attempting to fetch gpgme-1.14.0_0.darwin_20.arm64.tbz2 from https://mse.uk.packages.macports.org/gpgme
--->  Attempting to fetch gpgme-1.14.0_0.darwin_20.arm64.tbz2.rmd160 from https://mse.uk.packages.macports.org/gpgme
--->  Installing gpgme @1.14.0_0
--->  Activating gpgme @1.14.0_0
--->  Cleaning gpgme
--->  Fetching archive for perl5
--->  Attempting to fetch perl5-5.28.3_0+perl5_28.darwin_20.noarch.tbz2 from https://mse.uk.packages.macports.org/perl5
--->  Attempting to fetch perl5-5.28.3_0+perl5_28.darwin_20.noarch.tbz2.rmd160 from https://mse.uk.packages.macports.org/perl5
--->  Installing perl5 @5.28.3_0+perl5_28
--->  Activating perl5 @5.28.3_0+perl5_28
--->  Cleaning perl5
--->  Fetching archive for boehmgc
--->  Attempting to fetch boehmgc-8.0.4_1.darwin_20.arm64.tbz2 from https://mse.uk.packages.macports.org/boehmgc
--->  Attempting to fetch boehmgc-8.0.4_1.darwin_20.arm64.tbz2.rmd160 from https://mse.uk.packages.macports.org/boehmgc
--->  Installing boehmgc @8.0.4_1
--->  Activating boehmgc @8.0.4_1
--->  Cleaning boehmgc
--->  Fetching archive for w3m
--->  Attempting to fetch w3m-0.5.3-38_0.darwin_20.arm64.tbz2 from https://mse.uk.packages.macports.org/w3m
--->  Attempting to fetch w3m-0.5.3-38_0.darwin_20.arm64.tbz2 from https://lil.fr.packages.macports.org/w3m
--->  Attempting to fetch w3m-0.5.3-38_0.darwin_20.arm64.tbz2 from https://cph.dk.packages.macports.org/w3m
--->  Fetching distfiles for w3m
--->  Attempting to fetch w3m-0.5.3.tar.gz from https://mse.uk.distfiles.macports.org/w3m
--->  Verifying checksums for w3m
--->  Extracting w3m
--->  Applying patches to w3m
--->  Configuring w3m
Warning: Configuration logfiles contain indications of -Wimplicit-function-declaration; check that features were not accidentally disabled:
  exit: found in config.log
  printf: found in config.log
--->  Building w3m
Error: Failed to build w3m: command execution failed
Error: See /opt/local/var/macports/logs/_opt_mports_macports-ports_www_w3m/w3m/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port neomutt failed

I will attach the w3m build specific log file to this ticket.

Note that I use macports-base and macports-ports from github.

Attachments (1)

main.log (63.2 KB) - added by raw-bin (Robin Randhawa) 5 months ago.

Download all attachments as: .zip

Change History (3)

Changed 5 months ago by raw-bin (Robin Randhawa)

Attachment: main.log added

comment:1 Changed 5 months ago by jmroot (Joshua Root)

Port: w3m added; neomutt removed
Summary: neomutt installation failure on Big Sur on M1 Apple Silicon (w3m related)w3m @0.5.3-38 build failure on Big Sur on M1 Apple Silicon

comment:2 Changed 5 months ago by ryandesign (Ryan Schmidt)

Keywords: catalina added; arm64 removed
Resolution: duplicate
Status: newclosed

Duplicate of #61356.

Note: See TracTickets for help on using tickets.