Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#62008 closed defect (duplicate)

stack build failure

Reported by: jrquinello (jrquinello) Owned by: essandess (Steve Smith)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: stack

Description

I've been trying to install macos-fortress for a few days now but the package is not built. I attached the log this time. Thank you for your help.

Attachments (2)

error_macos-fortress.rtf (15.7 KB) - added by jrquinello (jrquinello) 4 months ago.
main.log (499.1 KB) - added by jrquinello (jrquinello) 4 months ago.

Download all attachments as: .zip

Change History (7)

Changed 4 months ago by jrquinello (jrquinello)

Attachment: error_macos-fortress.rtf added

comment:1 Changed 4 months ago by mf2k (Frank Schima)

Please instead attach the main.log file.

comment:2 Changed 4 months ago by jrquinello (jrquinello)

➜  ~ cd /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_stack/stack/main.log
cd: not a directory: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_stack/stack/main.log
➜  ~ nano /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_stack/stack/main.log

...s/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_stack/stack/main.log Modificado
:info:build 1 warning generated.
:info:build warning: unknown warning option '-Wno-nonportable-include-path'; did you mean '-Wno-gnu-include-next'? [-Wu>
:info:build 1 warning generated.
:info:build [1 of 4] Compiling Build_stack
:info:build [2 of 4] Compiling Paths_stack
:info:build [3 of 4] Compiling BuildInfo
:info:build [4 of 4] Compiling Main
:info:build warning: unknown warning option '-Wno-nonportable-include-path'; did you mean '-Wno-gnu-include-next'? [-Wu>
:info:build 1 warning generated.
:info:build warning: unknown warning option '-Wno-nonportable-include-path'; did you mean '-Wno-gnu-include-next'? [-Wu>
:info:build 1 warning generated.
:info:build Linking .stack-work/dist/x86_64-osx/Cabal-2.4.0.1/build/stack/stack ...
:info:build Undefined symbols for architecture x86_64:
:info:build   "_utimensat", referenced from:
:info:build       _cazW_info in libHSdirectory-1.3.3.0.a(Posix.o)
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build `clang' failed in phase `Linker'. (Exit code: 1)
:info:build Completed 161 action(s).
:info:build --  While building package stack-2.5.1 (scroll up to its section to see the error) using:
:info:build       /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_por>
:info:build     Process exited with code: ExitFailure 1
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_relea>
:info:build Exit code: 1
:error:build Failed to build stack: command execution failed
:debug:build Error code: CHILDSTATUS 4211 1
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports>
Last edited 4 months ago by jmroot (Joshua Root) (previous) (diff)

comment:3 Changed 4 months ago by jmroot (Joshua Root)

Owner: set to essandess
Port: stack added
Status: newassigned
Summary: macos-fortress does not install.stack build failure

Don't paste the text into a comment, use the "Attach file" button and select the main.log.

comment:4 Changed 4 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: assignedclosed

Duplicate of #60477.

Changed 4 months ago by jrquinello (jrquinello)

Attachment: main.log added

comment:5 Changed 4 months ago by jrquinello (jrquinello)

Sorry. I'm having problems attaching files, so I sent them by text, but here is an attachment.

Note: See TracTickets for help on using tickets.