Opened 3 months ago

Closed 3 months ago

#62037 closed defect (duplicate)

mpich-default: Undefined symbols

Reported by: MiloCheng17 Owned by: eborisch (Eric A. Borisch)
Priority: Normal Milestone:
Component: ports Version:
Keywords: bigsur Cc:
Port: mpich-default

Description

Trying to install mopish-default, got error "ld: symbol(s) not found for architecture x86_64"

Attachments (2)

main.log.zip (257.1 KB) - added by MiloCheng17 3 months ago.
main.log.2.zip (263.6 KB) - added by joseedil (Jose Edil Medeiros) 3 months ago.
main_1.log.zip

Download all attachments as: .zip

Change History (5)

Changed 3 months ago by MiloCheng17

Attachment: main.log.zip added

comment:1 Changed 3 months ago by joseedil (Jose Edil Medeiros)

Got the same error in OSX 11.1 when trying to install Octave. Tried the solution in comment:ticket:58333:8 with no success.

Last edited 3 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 3 months ago by joseedil (Jose Edil Medeiros)

Attachment: main.log.2.zip added

main_1.log.zip

comment:2 Changed 3 months ago by mf2k (Frank Schima)

Cc: eborisch removed
Owner: set to eborisch
Status: newassigned

comment:3 Changed 3 months ago by ryandesign (Ryan Schmidt)

Keywords: bigsur added
Resolution: duplicate
Status: assignedclosed
Summary: mpich-default install errormpich-default: Undefined symbols

This is probably the well-known macOS 11+ libtool bug, which has nothing to do with #58333.

Duplicate of #61909.

Note: See TracTickets for help on using tickets.