Opened 3 months ago

Closed 3 months ago

#62125 closed enhancement (duplicate)

openjdk 8u275 is only supported on Mac OS X 10.10 Yosemite or later.

Reported by: Piipperi (Piipperi) Owned by: breun (Nils Breunese)
Priority: Normal Milestone:
Component: website Version:
Keywords: Cc:
Port: openjdk8

Description

MacPorts site for openjdk8 says it supports 10.6 and above, but it clearly doesn't (tested on 10.8.5).

Change History (4)

comment:1 Changed 3 months ago by Piipperi (Piipperi)

This same also happens on openjdk11 and 15

comment:2 Changed 3 months ago by mf2k (Frank Schima)

Owner: set to breun
Status: newassigned
Type: defectenhancement
Version: 2.6.4

comment:3 Changed 3 months ago by breun (Nils Breunese)

The Portfile contains an explicit check for Mac OS X 10.10 Yosemite or later: https://github.com/macports/macports-ports/blob/master/java/openjdk/Portfile#L307-L314

I don't know how I can make https://ports.macports.org/port/openjdk8/summary reflect this. I'll ask on the developer mailinglist.

Last edited 3 months ago by breun (Nils Breunese) (previous) (diff)

comment:4 Changed 3 months ago by jmroot (Joshua Root)

Component: portswebsite
Resolution: duplicate
Status: assignedclosed

The current version of the port has never been built on 10.6-10.9. The issue is that the port health indicator looks at the most recent build on a given platform, regardless of whether it was for the current version of the port. (If you open the "Build Information" tab and scroll down, you'll see some successful builds for < 10.10.)

This issue is already tracked at https://github.com/macports/macports-webapp/issues/135.

Note: See TracTickets for help on using tickets.