Opened 3 months ago

Closed 3 months ago

#62355 closed enhancement (fixed)

py-ansible-base @2.10.6: Missing dependency py-packaging

Reported by: danieltrautmann (Daniel Trautmann) Owned by: adfernandes@…
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: haspatch Cc: pedro.salgado@…
Port: py-ansible-base

Description

During an Ansible run I got the following warning:

[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements

According to this discussion, this warning occurs when the dependency packaging is not installed.

I'll prepare a pull request for that, since I already added this dependency in my local MacPorts repo and the warning is gone now.

Change History (1)

comment:1 Changed 3 months ago by danieltrautmann (Daniel Trautmann)

Resolution: fixed
Status: assignedclosed

In d48ff9963737a6aae86af278417ec0b356094436/macports-ports (master):

py-ansible-base: Add dependency py-packaging

A warning is shown at the start of an Ansible run with the following
message:

[WARNING]: packaging Python module unavailable; unable to validate
collection Ansible version requirements

The added dependency fixes this warning.

Closes: #62355

Note: See TracTickets for help on using tickets.