Opened 7 weeks ago

Closed 8 days ago

#62363 closed defect (fixed)

mas @1.8.0 build fails on catalina

Reported by: conleym (Mike Conley) Owned by: kimuraw (kimura wataru)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: mas

Description

% sudo port install mas
--->  Computing dependencies for mas
--->  Fetching archive for mas
--->  Attempting to fetch mas-1.8.0_0.darwin_19.x86_64.tbz2 from https://ywg.ca.packages.macports.org/mirror/macports/packages/mas
--->  Attempting to fetch mas-1.8.0_0.darwin_19.x86_64.tbz2 from https://lil.fr.packages.macports.org/mas
--->  Attempting to fetch mas-1.8.0_0.darwin_19.x86_64.tbz2 from https://mse.uk.packages.macports.org/mas
--->  Building mas
Error: Failed to build mas: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_sysutils_mas/mas/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port mas failed

Attachments (1)

main.log (725.0 KB) - added by conleym (Mike Conley) 7 weeks ago.
build log

Download all attachments as: .zip

Change History (6)

Changed 7 weeks ago by conleym (Mike Conley)

Attachment: main.log added

build log

comment:1 Changed 7 weeks ago by mf2k (Frank Schima)

Cc: kimuraw removed
Owner: set to kimuraw
Status: newassigned

comment:2 Changed 7 weeks ago by kencu (Ken)

modules are going to be a problem...

comment:3 Changed 9 days ago by kimuraw (kimura wataru)

this problem is not solved? installation with macOS 10.15 and Xcode 11.5 succeeded on my Mac.

% xcodebuild -version                        
Xcode 11.5
Build version 11E608c
% uname -r                                   
19.6.0
% port installed mas                         
The following ports are currently installed:
  mas @1.8.1_0 (active)

comment:4 Changed 9 days ago by conleym (Mike Conley)

I can confirm that 1.8.1 installed cleanly for me with xcode 12.4.

% sudo port install mas                                                                                                                                        
Portfile changed since last build; discarding previous state.
--->  Fetching archive for mas
--->  Attempting to fetch mas-1.8.1_0.darwin_19.x86_64.tbz2 from https://ywg.ca.packages.macports.org/mirror/macports/packages/mas
--->  Attempting to fetch mas-1.8.1_0.darwin_19.x86_64.tbz2.rmd160 from https://ywg.ca.packages.macports.org/mirror/macports/packages/mas
--->  Installing mas @1.8.1_0
--->  Activating mas @1.8.1_0
--->  Cleaning mas
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  No broken files found.
--->  No broken ports found.

% uname -r                                                                                                                                                   
19.6.0

% xcodebuild -version
Xcode 12.4
Build version 12D4e

Last edited 8 days ago by conleym (Mike Conley) (previous) (diff)

comment:5 Changed 8 days ago by kimuraw (kimura wataru)

Resolution: fixed
Status: assignedclosed

thanks your confirming!

Note: See TracTickets for help on using tickets.