Opened 6 months ago

Last modified 6 months ago

#62637 assigned defect

creduce @2.10.0 : depends on clang-8.0 which doesn't work on Big Sur

Reported by: c-kloukinas Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: BigSur Cc:
Port: creduce

Description

Can it be built with a newer version of clang that's supported in BigSur?

Change History (2)

comment:1 Changed 6 months ago by jmroot (Joshua Root)

Cc: larryv@… removed
Owner: set to larryv
Status: newassigned
Summary: creduce @2.10.0 : depends on broken and abandoned (BigSur) clang-8.0creduce @2.10.0 : depends on clang-8.0 which doesn't work on Big Sur

comment:2 Changed 6 months ago by kencu (Ken)

we were supposed to update the clang dep to 9.0 when we upgraded to creduce 2.10

<https://github.com/csmith-project/creduce/blob/master/INSTALL.md>

and that is working on BigSur Intel <http://packages.macports.org/clang-9.0/>.

For BigSur arm64, we should use llvm-11/clang-11. There is a creduce branch for that, and a fairly simple patch from that branch here <https://github.com/csmith-project/creduce/commit/3e1f5a1ec1365fafae965c97603221c9ccbc2d61> that does the actual llvm-11 fix.

So looks all doable.

Note: See TracTickets for help on using tickets.