Opened 8 months ago

Closed 2 months ago

#62647 closed defect (fixed)

python39 @3.9.4_0+optimizations: fails to compile if macports llvm is selected

Reported by: hugo-ribeiro (Hugo Ribeiro) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: larryv (Lawrence Velázquez)
Port: python39 python310

Description

python39 +optimizations fails to compile if one has set llvm to mp-llvm-11 via

port select llvm mp-llvm-11

(it's the only version installed on my system so I couldn't try if this behavior is also true with earlier versions of llvm set as default).

Setting

port select llvm none

solves the issue.

I'm guessing that this is not the intended behavior and that the system llvm (/usr/bin/llvm) should be selected by default during the configuration phase.

Attachments (2)

main.log (361.6 KB) - added by hugo-ribeiro (Hugo Ribeiro) 8 months ago.
config.log (885.0 KB) - added by hugo-ribeiro (Hugo Ribeiro) 8 months ago.

Download all attachments as: .zip

Change History (6)

Changed 8 months ago by hugo-ribeiro (Hugo Ribeiro)

Attachment: main.log added

Changed 8 months ago by hugo-ribeiro (Hugo Ribeiro)

Attachment: config.log added

comment:1 Changed 8 months ago by mf2k (Frank Schima)

Cc: jmroot removed
Owner: set to jmroot
Status: newassigned

comment:2 Changed 4 months ago by larryv (Lawrence Velázquez)

Cc: larryv added

comment:3 Changed 2 months ago by jmroot (Joshua Root)

Port: python310 added

comment:4 Changed 2 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

In edfccb779962684697089929f2b687ff9d44df02/macports-ports (master):

python3{9,10,11}: avoid 'port select'ed llvm tools

Fixes: #62647

Note: See TracTickets for help on using tickets.