Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#62721 closed defect (fixed)

qmake5 PG and legacysupport PG do not work together

Reported by: szhorvat (Szabolcs Horvát) Owned by: Chris Jones <jonesc@…>
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cjones051073 (Chris Jones), kencu (Ken)
Port:

Description

Linking flags set by the legacysupport portgroup are not picked up by the qmake5 portgroup. See discussion here:

https://github.com/macports/macports-ports/commit/793d1f843e0bb8e7b8327ed3e4509aade9f83aae

It seems legacysupport sets LDFLAGS, but this variable is ignored by the qmake5 PG. Instead, one needs to add QMAKE_LFLAGS+=... to the configure args to control linking.

Change History (4)

comment:1 Changed 7 months ago by cjones051073 (Chris Jones)

I suspect the best way forward here is to augment the qmake5 PG to use leacysupport directly, as then it will 'known' when it has to use it and can add the flags are required wherever it needs... I'll have a quick look.

comment:2 Changed 7 months ago by szhorvat (Szabolcs Horvát)

Looking at the qmake (i.e. Qt4) portgroup, it seems to transfer all linker and compiler options. I wonder why qmake5 does not also do it.

comment:3 Changed 7 months ago by Chris Jones <jonesc@…>

Owner: set to Chris Jones <jonesc@…>
Resolution: fixed
Status: newclosed

In 51ad9d1e539d33e7eaa717da62c933f79ee03778/macports-ports (master):

qmake5 PG: Respect link flags for legacysupport
Closes: #62721

comment:4 in reply to:  2 Changed 7 months ago by cjones051073 (Chris Jones)

Replying to szhorvat:

Looking at the qmake (i.e. Qt4) portgroup, it seems to transfer all linker and compiler options. I wonder why qmake5 does not also do it.

Yeah, was not sure myself why it was so specific in picking and choosing the options to pass...

Note: See TracTickets for help on using tickets.