Opened 19 months ago

Last modified 19 months ago

#62852 assigned enhancement

root6: Enable python variant by default on all systems?

Reported by: ryandesign (Ryan Schmidt) Owned by: cjones051073 (Chris Jones)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: mojca (Mojca Miklavec)
Port: root6

Description

Ever since [8e81e8412af71d36dffff46216c2f3dc4c957900/macports-ports] root6 enables a python variant by default only on OS X 10.9 or later. The justification given is:

# Enable python variant by default on OSX 10.9 and newer.
# Disabled on older systems due to an issue fetching the source for
# the various python dependencies due to these systems having out of
# date SSL versions that are rejected by the upstram server.

I don't understand the justification. Why can't the variant be enabled by default on all systems? MacPorts maintains mirror servers that mirror distfiles, and packages servers that provide binary archives, for all sytsems, regardless of their SSL capabilities.

Change History (1)

comment:1 Changed 19 months ago by cjones051073 (Chris Jones)

Hmmm, I guess it must have been an issue at the time that was added, but that could have been a while ago.

The only way is to try removing it and see I guess.

Note: See TracTickets for help on using tickets.