Opened 2 weeks ago

#62995 new defect

restore_ports fails during migration to macOS 11.[34] (Big Sur) with "requested variants do not match" and also complains "macOS 11 SDK does not appear to be installed"

Reported by: MarkCallow (Mark Callow) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc:
Port:

Description

I am migrating my MacPorts installation from macOS Catalina to Big Sur. During restore_ports.tcl I've had several errors like the following:

Error: Requested variants "+python39" do not match those the build was started with: "+python37".
Error: Please use the same variants again, or run 'port clean xorg-libxcb' first to remove the existing partially completed build.
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libxcb/xorg-libxcb/main.log for details.

I tried just re-running and doing port clean xorg-libxcb then re-running. There was no change. As only an occasional user of macports, I do not understand "variants" nor how to specify them to the port command.

Also many times during restore_ports.tcl the waarning

Warning: The macOS 11 SDK does not appear to be installed. Ports may not build correctly.
Warning: You can install it as part of the Xcode Command Line Tools package by running `xcode-select --install'.

is printed. I have Xcode 12.5 installed and I do have the command line tools installed. When I run xcode-select --install I get the message

xcode-select: error: command line tools are already installed, use "Software Update" to install updates

Change History (0)

Note: See TracTickets for help on using tickets.