Opened 2 months ago

Closed 8 weeks ago

#63403 closed defect (invalid)

R @4.1.1 fails to build: LaTeX Error: File `fancyvrb.sty' not found.

Reported by: msrski59 Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: i0ntempest, msrski59
Port: R

Description

on macOS Big Sur 11.2.3, using Xcode 12.5.1, R-4.1.1 fails to build with this output at the end:

make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_R/R/work/R-4.1.1/src/library/Recommended'
Error: compiling TeX file 'reshape.tex' failed with message:
Running 'texi2dvi' on 'reshape.tex' failed.
LaTeX errors:
! LaTeX Error: File `fancyvrb.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

! Emergency stop.
<read *> 
         
l.19 \begingroup
                ^^M
!  ==> Fatal error occurred, no output PDF file produced!
Execution halted
make[1]: *** [vignettes] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_R/R/work/R-4.1.1/src/library'
make: *** [vignettes] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_R/R/work/R-4.1.1'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_R/R/work/R-4.1.1" && /usr/bin/make -j8 -w all 
Exit code: 2
Error: Failed to build R: command execution failed

Full log attached.

Attachments (1)

main.log.gz (45.4 KB) - added by msrski59 2 months ago.

Download all attachments as: .zip

Change History (8)

Changed 2 months ago by msrski59

Attachment: main.log.gz added

comment:1 Changed 2 months ago by msrski59

Cc: msrski59 added

comment:2 Changed 2 months ago by msrski59

Cc: msrski59 removed

comment:3 Changed 2 months ago by msrski59

Cc: msrski59 added

comment:4 Changed 2 months ago by jmroot (Joshua Root)

Cc: i0ntempest added; kjell.konis@… removed
Owner: set to kjellpk
Status: newassigned
Summary: R-4.1.1 fails to buildR @4.1.1 fails to build: LaTeX Error: File `fancyvrb.sty' not found.

comment:5 Changed 2 months ago by i0ntempest

Possible duplicate of https://trac.macports.org/ticket/63369. Try reinstalling latex.

comment:6 Changed 8 weeks ago by msrski59

Reinstalled texlive-latex, texlive-latex-extra, texlive-latex-recommended.

Success. R @4.1.1 now builds. Thanks i0ntempest.

comment:7 Changed 8 weeks ago by i0ntempest

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.