Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#63448 closed defect (duplicate)

cctools @949.0.1_1+llvmdev: "otool -L" does not work properly, incorrectly passed '-macho' option to llvm-objdump

Reported by: cave-canem Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), cave-canem
Port: cctools

Description (last modified by cave-canem)

It seems to me that the "otool -L" does not work properly — incorrect '-macho' option for llvm-objdump is passed.

Example:

otool -L $(which bash)
llvm-objdump: Unknown command line argument '-macho'.  Try: '/opt/MacPorts/libexec/llvm-devel/bin/llvm-objdump --help'
llvm-objdump: Did you mean '-h'?
llvm-objdump: Unknown command line argument '-dylibs-used'.  Try: '/opt/MacPorts/libexec/llvm-devel/bin/llvm-objdump --help'
llvm-objdump: Did you mean '--dylibs-used'?
llvm-objdump: Unknown command line argument '-non-verbose'.  Try: '/opt/MacPorts/libexec/llvm-devel/bin/llvm-objdump --help'
llvm-objdump: Did you mean '--non-verbose'?

Change History (13)

comment:1 Changed 17 months ago by cave-canem

Description: modified (diff)
Summary: cctools @949.0.1_1+llvmdev: "otool -L" does not work properly, incorrectly passed 'macho' option to llvm-objdumpcctools @949.0.1_1+llvmdev: "otool -L" does not work properly, incorrectly passed '-macho' option to llvm-objdump

comment:2 Changed 17 months ago by kencu (Ken)

Yeppers, cctools +llvmdev does not work properly, indeed, at the moment at least.

We discovered this a while back, and we noted the same thing here in this ticket you posted 63330 a month ago.

I thought perhaps I convinced you then not to use cctools +llvmdev for now at least. It's a non-standard variant, used for testing things ("dev"), and right now cctools +llvmdev doesn't work too well.

I suggest you don't use it at the moment, and use cctools +llvm10 (the default, I believe).

comment:3 Changed 17 months ago by kencu (Ken)

Cc: jeremyhu added; kencu cave-canem removed
Owner: set to kencu
Status: newassigned

comment:4 Changed 17 months ago by cave-canem

Ken, there are some differences in the behavior of cctools + llvmdev after upgrading lvm-devel to lvm-devel @ 20210401-d1828937_1.

Now there is no error "some libraries to be built with @rpath references", at least for "ffmpeg", as it was described in https://trac.macports.org/ticket/63330.

P.S.

...I suggest you don't use it at the moment, and use cctools +llvm10 (the default, I believe).

I'm just testing.

comment:5 Changed 17 months ago by kencu (Ken)

ok, we'll leave one open letting people know not to use this variant. I closed the other one for this issue instead.

comment:6 Changed 17 months ago by cave-canem

Cc: cave-canem added

comment:7 Changed 17 months ago by kencu (Ken)

you're already copied as the reporter, which is why I removed the redundant cc

comment:8 Changed 17 months ago by cave-canem

It should be added that "otool-classic" runs without any complaints:

otool-classic -L $(which bash)
/opt/MacPorts/bin/bash:
	/opt/MacPorts/lib/libncurses.6.dylib (compatibility version 6.0.0, current version 6.0.0)
	/opt/MacPorts/lib/libintl.8.dylib (compatibility version 10.0.0, current version 10.5.0)
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.17.0)
	/opt/MacPorts/lib/libiconv.2.dylib (compatibility version 9.0.0, current version 9.1.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)

comment:9 Changed 17 months ago by kencu (Ken)

duplicate of #61967

comment:10 Changed 17 months ago by blair (Blair Zajac)

Resolution: duplicate
Status: assignedclosed

comment:11 in reply to:  7 Changed 17 months ago by jmroot (Joshua Root)

Replying to kencu:

you're already copied as the reporter, which is why I removed the redundant cc

That used to be the case, but newer versions of Trac allow users to choose whether they receive mail when they are reporter but not in Cc.

comment:12 Changed 17 months ago by kencu (Ken)

OK, thanks Josh. I will heretofore refrain from my inherent neat-and-tidiness :!

comment:13 Changed 17 months ago by cave-canem

Hello Ken!

I wrote:

Now there is no error "some libraries to be built with @rpath references",

at least for "ffmpeg", as it was described in https://trac.macports.org/ticket/63330.

I was wrong because I was building "ffmpeg" with "dav1d" already correctly built.

I tried building "dav1d @ 0.9.2_0" and got "libraries to be built with @rpath references" again.

It seems https://trac.macports.org/ticket/63330 needs to be changed status to "assigned".

Forgive me for misleading you.

Note: See TracTickets for help on using tickets.