#63484 closed update (fixed)

updated Portfile for py-pyfftw

Reported by: bernard-giroux (Bernard Giroux) Owned by: lpsinger (Leo Singer)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-pyfftw

Description

I could install an updated version of pyfftw with the attached portfile.

Attachments (2)

Portfile (1.5 KB) - added by bernard-giroux (Bernard Giroux) 17 months ago.
diff.out (1.2 KB) - added by bernard-giroux (Bernard Giroux) 17 months ago.

Download all attachments as: .zip

Change History (6)

Changed 17 months ago by bernard-giroux (Bernard Giroux)

Attachment: Portfile added

comment:1 Changed 17 months ago by reneeotten (Renee Otten)

Owner: set to lpsinger
Status: newassigned
Version: 2.7.99

thanks for the update Bernard! To get this incorporated more quickly, submitting a PR to https://github.com/macports/macports-ports is highly preferred (otherwise you should attached a unified diff). A cursory glance at it shows that you updated the port (good!) but also added configure.cflags-append -Wno-error=implicit-function-declaration , not as good ;) We preferable don't want to do that as it just doesn't error out but the problem remains; instead the correct header(s) should be added, or perhaps you added this to get rid of the warnings that MacPorts prints out?

comment:2 Changed 17 months ago by bernard-giroux (Bernard Giroux)

Hi

I added the flag because otherwise the port does not install. The developers of pyfftw use a custom approach to find the fftw library, and the flag is needed for that purpose.

It looks like they are aware that this flag is needed on macOS to get the port installed, but for now they have not updated their script.

Changed 17 months ago by bernard-giroux (Bernard Giroux)

Attachment: diff.out added

comment:3 Changed 17 months ago by reneeotten (Renee Otten)

please add the main.log of a clean, failed build so we can see what the problem is

comment:4 Changed 15 months ago by reneeotten (Renee Otten)

Resolution: fixed
Status: assignedclosed

In be49c4b82201be3d3daffa18e810b81895d2e8a2/macports-ports (master):

py-pyfftw: update to 0.12.0, add py3{7-9} subports

Closes: #63484

Note: See TracTickets for help on using tickets.