Opened 15 years ago

Closed 15 years ago

#6349 closed defect (duplicate)

emacs (+carbon) completion problem

Reported by: opendarwin@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

A fresh install of darwinports. I installed the carbon emacs-devel port. It all seems to work OK, apart from completion (of filenames and commands) giving the following error in the *Messages* buffer:

Making completion list... run-hooks: Wrong type argument: stringp, #<objfwd to t>

treaclebrain:~ gs$ port version Version: 1.200

treaclebrain:~ gs$ type -a port port is /opt/local/bin/port treaclebrain:~ gs$ sudo port install emacs-devel +carbon Password: ---> Fetching emacs-devel ---> Verifying checksum(s) for emacs-devel ---> Extracting emacs-devel ---> Applying patches to emacs-devel ---> Configuring emacs-devel ---> Building emacs-devel with target bootstrap ---> Staging emacs-devel into destroot ---> Packaging tgz archive for emacs-devel 22.0.50.1_0+carbon+darwin_8 ---> Installing emacs-devel 22.0.50.1_0+carbon+darwin_8 ---> Activating emacs-devel 22.0.50.1_0+carbon+darwin_8 ---> Cleaning emacs-devel treaclebrain:~ gs$

Change History (2)

comment:1 Changed 15 years ago by opendarwin@…

Thanks to Mark Dickinson for the following:

The culprit is the line

cvs.args -D20051018

in the emacs-devel portfile, which instructs cvs to check out a revision that's dated no later than Oct 18, 2005. I managed to fix the problem by simply changing this (in my local portfile repository) to use a more recent date; e.g. -D20060103. There's some old emacs bug present in that particular revision that's long since been fixed.

He also pointed out bug#6186, which seems to say this has already been fixed

comment:2 Changed 15 years ago by opendarwin@…

Resolution: duplicate
Status: newclosed

bug#6186 has now (really) been fixed, and this is effectively a dupe of that, so resolving

* This bug has been marked as a duplicate of 6186 *

Note: See TracTickets for help on using tickets.