#63646 closed defect (worksforme)

mtpaint no longer runs -- Symbol not found in libgtk-x11-2.0.0.dylib

Reported by: RobK88 Owned by: mascguy (Christopher Nielsen)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: lion Cc: kencu (Ken)
Port: mtpaint, gtk2

Description

mtpaint no longer runs on lion. It used to run just fine. Symbol not found in libgtk-x11-2.0.0.dylib

bash-3.2$ mtpaint
dyld: Symbol not found: _g_cclosure_marshal_VOID__VOID
  Referenced from: /opt/local/bin/mtpaint
  Expected in: /opt/local/lib/libgtk-x11-2.0.0.dylib
 in /opt/local/bin/mtpaint
Trace/BPT trap: 5

Change History (5)

comment:1 Changed 16 months ago by mascguy (Christopher Nielsen)

Owner: set to mascguy
Status: newassigned

While I haven't looked at this port before, there's a chance that it's an issue with gtk2. So I'll try to help with this.

comment:2 Changed 16 months ago by RobK88

Thanks. My guess is mtpaint may need an older version of the gtk+ library. Previously, I installed mtpaint via macports and it ran just fine. But now it does not. I suspect the issue is not confined to Macs running Lion.

comment:3 Changed 16 months ago by RobK88

I just downloaded mtpaint version 3.5 directly from the developer's website. I was able to compile and install it into /usr/local/bin

./configure
make
su AdminAccount
sudo make install

And it runs just fine.

I will try to reinstall the port of mtpaint and see what happens.

comment:4 Changed 16 months ago by RobK88

I uninstalled the mtpaint port and reinstalled it. Now the port runs just fine. I do not know what broke it in the first place.

In any event, please note that the port for mtpaint is very old -- Version 3.31

The current version of mtpaint is version 3.50 which appears to run just fine on my Mac running Lion. When someone has a chance, I recommend that the port for mtpaint be updated to version 3.50.

comment:5 Changed 16 months ago by mascguy (Christopher Nielsen)

Resolution: worksforme
Status: assignedclosed

Great, glad the issue is resolved!

And new ticket created, to cover the update: issue:63649

Note: See TracTickets for help on using tickets.