Opened 7 months ago

Last modified 5 months ago

#63702 assigned defect

rust @1.56.0_2 failure to destroot on M1 / Monterey

Reported by: jamesrtnz Owned by: g5pw (Aljaž Srebrnič)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: herbygillot (Herby Gillot), FaradayLight (Faraday Light)
Port: rust


New installation of MacPorts on an Apple Silicon M1 running MacOS Monterey release version 12.0.1.

Attempt to install "rust" fails:

--->  Staging rust into destroot
Error: Failed to destroot rust: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/main.log for details.
Error: Follow if you believe there
is a bug.
Error: Processing of port rust failed

From main.log:

:info:destroot command did not execute successfully: "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/aarch64-apple-darwin/stage0-tools-bin/fabricate" "generate" "--image-dir" "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/tmp/tarball/rust-std/aarch64-apple-darwin/image" "--component-name=rust-std-aarch64-apple-darwin" "--rel-manifest-dir=rustlib" "--legacy-manifest-dirs=rustlib,cargo" "--product-name=Rust" "--success-message=rust-std installed." "--package-name=rust-std-1.56.0-aarch64-apple-darwin" "--non-installed-overlay" "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/tmp/tarball/rust-std/aarch64-apple-darwin/overlay" "--output-dir" "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/dist" "--work-dir" "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/tmp/tarball/rust-std/aarch64-apple-darwin"
:info:destroot expected success, got: signal: 9
:info:destroot Traceback (most recent call last):
:info:destroot   File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/src/bootstrap/", line 1231, in <module>
:info:destroot     main()
:info:destroot   File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/src/bootstrap/", line 1214, in main
:info:destroot     bootstrap(help_triggered)
:info:destroot   File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/src/bootstrap/", line 1200, in bootstrap
:info:destroot     run(args, env=env, verbose=build.verbose, is_bootstrap=True)
:info:destroot   File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/src/bootstrap/", line 153, in run
:info:destroot     raise RuntimeError(err)
:info:destroot RuntimeError: failed to run: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_rust/rust/work/rustc-1.56.0-src/build/bootstrap/debug/bootstrap install -v
:info:destroot make: *** [install] Error 1

Full log attached.

Attachments (1)

main.log.bz2 (1.3 MB) - added by jamesrtnz 7 months ago.
Compressed "main.log" from failed build of rust on MacOS Monterrey / M1

Download all attachments as: .zip

Change History (7)

Changed 7 months ago by jamesrtnz

Attachment: main.log.bz2 added

Compressed "main.log" from failed build of rust on MacOS Monterrey / M1

comment:1 Changed 7 months ago by jamesrtnz

Sorry, this may have been a transient issue; I did try the port install operation several times with similar failures; but after a complete restart of the MacBook it succeeded.

This ticket can probably be closed.

comment:2 Changed 7 months ago by pcostanza (Pascal Costanza)

I have the same issue, same configuration, same last few lines in the main.log. A reboot of my MacBook didn't help.

comment:3 Changed 6 months ago by jlwitthuhn

I have also seen this problem with package version 1.56.1_0 on an M1 MBP with MacOS 12 and Xcode 13.1.

The first attempt to build and install failed with the same error in the original report, then a 'port clean rust' and a second attempt at building worked.

comment:4 Changed 6 months ago by FaradayLight (Faraday Light)

This item appears to have been resolved in rust package @1.56.1_1 for Monterey on arm64

Last edited 6 months ago by FaradayLight (Faraday Light) (previous) (diff)

comment:5 Changed 6 months ago by FaradayLight (Faraday Light)

Cc: FaradayLight added

comment:6 Changed 5 months ago by jlwitthuhn

I'm still seeing this occasionally with 1.57.0_1 on M1 MacOS 12.1 and Xcode 13.1.

What I've learned since I last commented is that I don't actually need to do a clean and rebuild to resolve this problem. If I just run the install command again, the already-built files will successfully destroot.

Note: See TracTickets for help on using tickets.