Opened 15 years ago

Closed 15 years ago

#6376 closed defect (fixed)

New Subversion port breaks 'without_neon' variant...

Reported by: gad@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The new darwinport for subversion 1.3.0 still has the variant for 'without_neon', but now that variant doesn't work quite right. It will download and build neon. I suspect the problem is that the new port now has a 'depends_lib port:neon', but the variant says 'depends-lib-delete lib:libneon:24.0.7:neon'. So, whatever code does the lib-deleting probably sees those as two unrelated things, and does not delete the dependency on neon.

Change History (1)

comment:1 Changed 15 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

You're right.

I've just committed a fixed version of the portfile.

Note: See TracTickets for help on using tickets.