Opened 12 days ago

Last modified 30 hours ago

#64042 assigned defect

py39-poppler-qt5 @0.75.0_1: sip: Unable to find file "QtCore/QtCoremod.sip"

Reported by: JunTamura1959 Owned by: dliessi (Davide Liessi)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: monterey Cc:
Port: py-poppler-qt5

Description (last modified by ryandesign (Ryan Schmidt))

py39-poppler-qt5-0.75.0_1.darwin_21.x86_64 failed to build on Monterey with:

Error: Failed to build py39-poppler-qt5: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-poppler-qt5/py39-poppler-qt5/main.log for details.

Attachments (1)

main.log (18.0 KB) - added by JunTamura1959 12 days ago.
Originally /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-poppler-qt5/py39-poppler-qt5/main.log

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 days ago by reneeotten (Renee Otten)

Owner: set to dliessi
Port: py-poppler-qt5 added; py39-poppler-qt5 removed
Status: newassigned

please add the main.log file mentioned in the error message to this ticket

Changed 12 days ago by JunTamura1959

Attachment: main.log added

Originally /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-poppler-qt5/py39-poppler-qt5/main.log

comment:2 Changed 12 days ago by reneeotten (Renee Otten)

I update the port a while ago, but didn't properly take care of the PY27 and earlier Python versions. If you want you can give it a try though and perhaps Davide can open a PR with his latest changes to try and get this merged.

comment:3 Changed 4 days ago by reneeotten (Renee Otten)

In 068721d8c2ae76a0f83d0e8bf36be9a46a67b80b/macports-ports (master):

py-poppler-qt5: update to 21.1.0, build with latest SIP

See https://github.com/macports/macports-ports/pull/12450
See #64042

comment:4 Changed 4 days ago by reneeotten (Renee Otten)

JunTamura1959: can you please verify whether this commit fixed the issue (you might need to wait a few hours, then do a port selfupdate, and try to install again).

comment:5 Changed 30 hours ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: monterey added
Summary: py39-poppler-qt5 @0.75.0_1 failed to build on Montereypy39-poppler-qt5 @0.75.0_1: sip: Unable to find file "QtCore/QtCoremod.sip"

The relevant error in the log was actually:

sip: Unable to find file "QtCore/QtCoremod.sip"
Note: See TracTickets for help on using tickets.