Opened 11 months ago

Last modified 9 months ago

#64518 assigned enhancement

Use Qt5 LTS compilation patches git repository from KDE

Reported by: cgilles (HumanDynamo) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: chrstphrchvz (Christopher Chavez), mascguy (Christopher Nielsen)
Port: qt5

Description

Hi,

Current qt5 port use last 5.15.2 official tarball published to compile source code.

Since there is no Qt5.15 LTS tarball published as opensource by Qt team, KDE project has created a own git repository including all official security/improvement collection patches published in Qt5 project.

All main Linux distributions start to use this repository as source code reference to maintain the qt5 package as LTS for version > 5.15.2.

In digiKam project i used successfully this repository to compile the official Linux AppImage bundle. This allow to fix plenty of bugs in application due to UPSTREAM Qt bugs (as for ex. a compatibility with Mariadb >= 10.6 with Qt Mysql plugin).

The bug for digiKam relevant of this improvement is this one :

https://bugs.kde.org/show_bug.cgi?id=114417

The script used to checkout the KDE repository with AppImage Bundle compilation is here :

https://invent.kde.org/graphics/digikam/-/blob/master/project/bundles/3rdparty/ext_qt/5.15-LTS/kde-qt5-lts.sh

I highly recommend to use the KDE qt 5.15 LTS repository to maintain the qt5 port in Macports.

Best

Gilles Caulier

Change History (6)

comment:1 Changed 11 months ago by cgilles (HumanDynamo)

Note : In digiKam AppImage bundle, the Qt5 version reported by the library is 5.15.3 as you can see in this screenshot:

https://i.imgur.com/R7o2xoj.png

comment:2 Changed 11 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:3 Changed 11 months ago by jmroot (Joshua Root)

Owner: set to MarcusCalhoun-Lopez
Status: newassigned

comment:4 Changed 11 months ago by mascguy (Christopher Nielsen)

Cc: mascguy added

comment:5 Changed 9 months ago by chrstphrchvz (Christopher Chavez)

I asked about using the KDE patch collection a couple of times, but the only response was that doing so would be up to whoever is interested: https://lists.macports.org/pipermail/macports-dev/2021-October/043826.html, https://github.com/macports/macports-ports/pull/12711#issuecomment-958162641. And from my experience updating qt5-qtwebengine to newer releases, I’ve found that the current structure of qt5 portfile doesn’t easily accommodate using sources other than the official tarballs. The 5.15.3 sources are now publicly available, so maybe those can be used in the meantime.

comment:6 Changed 9 months ago by cgilles (HumanDynamo)

Hi,

Right Qt 5.15.3 is now out and must be used as well in Macports. Good point...

Best regards

Gilles Caulier

Last edited 9 months ago by cgilles (HumanDynamo) (previous) (diff)
Note: See TracTickets for help on using tickets.