Opened 7 months ago

Closed 6 months ago

#64731 closed defect (duplicate)

p5.28-wx: error: unknown type name 'class'

Reported by: tkaty22 Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: p5-wx

Description (last modified by jmroot (Joshua Root))

I keep getting this error message:

The following dependencies will be installed: 
 p5.28-wx
 p5.28-xmlrpc-lite
 p5.28-yaml-tiny
Continue? [Y/n]: y
--->  Fetching archive for p5.28-wx
--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_21.arm64.tbz2 from https://packages.macports.org/p5.28-wx
--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_21.arm64.tbz2 from https://mse.uk.packages.macports.org/p5.28-wx
--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_21.arm64.tbz2 from https://ema.uk.packages.macports.org/p5.28-wx
--->  Building p5.28-wx
Error: Failed to build p5.28-wx: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_perl_p5-wx/p5.28-wx/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets if you believe there
is a bug.
Error: Processing of port demeter failed

Attachments (1)

main.log.zip (956.8 KB) - added by JeanJackPg 7 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 months ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: macOS Monterey removed
Owner: set to mojca
Port: p5-wx added
Priority: HighNormal
Status: newassigned

Please attach the log.

comment:2 Changed 7 months ago by JeanJackPg

I got the same problem when building this port. I attach my log, in case anyone can help me!

Changed 7 months ago by JeanJackPg

Attachment: main.log.zip added

comment:3 Changed 6 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed
Summary: Failed to build p5.28-wxp5.28-wx: error: unknown type name 'class'

Duplicate of #61588.

Note: See TracTickets for help on using tickets.