Opened 5 months ago

Last modified 3 months ago

#64764 reopened defect

git contents has an non-existent folder/file - share/git-gui/lib/Git Gui.app/Contents/MacOS/Wish

Reported by: kurthindenburg (Kurt Hindenburg) Owned by: ci42
Priority: Normal Milestone:
Component: ports Version:
Keywords: monterey Cc: jleroy (Jonathan Leroy), breun (Nils Breunese), michaellass (Michael Lass), jowens (John Owens), i0ntempest, Schamschula (Marius Schamschula), fracai, blair (Blair Zajac), iay (Ian Young), catap (Kirill A. Korinsky), hnarayanan (Harish Narayanan), ylluminate (ylluminate)
Port: git

Description (last modified by ryandesign (Ryan Schmidt))

/opt/local/share/git-gui/lib/Git Gui.app/Contents/MacOS/Wish is in the contents but the file doesn't exist and causes errors on rev-upgrade.

--->  Scanning binaries for linking errors

Warning: Error parsing file /opt/local/share/git-gui/lib/Git Gui.app/Contents/MacOS/Wish: Error opening or reading file


share/git-gui/lib/Git Gui.app/ doesn't exist

git @2.35.1_0+credential_osxkeychain+diff_highlight+doc+pcre+perl5_28 (active)

port contents git  | grep -i wish
  /opt/local/share/git-gui/lib/Git Gui.app/Contents/MacOS/Wish

Change History (26)

comment:1 Changed 5 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

If /opt/local/share/git-gui/lib/Git Gui.app/Contents/MacOS/Wish does not exist on your disk after installing the git port, there is something wrong with your machine. It does exist on my machine.

Perhaps something deleted it after you installed the port. To get it back, you could:

sudo port -f deactivate git
sudo port activate git

comment:2 Changed 5 months ago by kurthindenburg (Kurt Hindenburg)

Resolution: invalid
Status: assignedclosed

I guess I should have thought of that. I wonder how it got deleted. The deactivate/activate worked. Thanks.

comment:3 Changed 5 months ago by fracai

Just wanted to note that I noticed this exact issue this morning and the deactivate/activate steps corrected the error. Aside from updating ports and updating the system to 12.2.1 I can't think of any actions that would have been messing with the /opt directory.

comment:4 Changed 5 months ago by mf2k (Frank Schima)

Me too. I keep doing the deactivate/activate fix and this error keeps popping up again. There is a bug somewhere.

comment:5 Changed 5 months ago by jmroot (Joshua Root)

Resolution: invalid
Status: closedreopened

comment:6 Changed 5 months ago by jleroy (Jonathan Leroy)

Cc: jleroy added

comment:7 Changed 5 months ago by breun (Nils Breunese)

This seems to be a duplicate of ticket:64243.

comment:8 Changed 5 months ago by breun (Nils Breunese)

I run into this issue after each macOS update (12.2, 12.2.1, 12.3). Reactivating is a workaround, but shouldn't be necessary.

comment:9 Changed 5 months ago by ryandesign (Ryan Schmidt)

Cc: breun added
Keywords: monterey added

Is everybody who experiences this problem running macOS 12 or later? Is everybody on arm64? I see this problem too on the macOS 12 arm64 buildbot worker.

Is the macOS update perhaps moving Git Gui.app somewhere else, such as into a Relocated Items or Incompatible Software folder? I can't find it.

It's sounding like a bug in macOS 12 to me.

comment:10 in reply to:  9 Changed 5 months ago by mf2k (Frank Schima)

Replying to ryandesign:

Is everybody who experiences this problem running macOS 12 or later?

Yes. macOS 12.

Is everybody on arm64?

No

comment:11 Changed 5 months ago by breun (Nils Breunese)

I've been experiencing this on macOS 12, but on an Intel Mac.

comment:12 Changed 5 months ago by neverpanic (Clemens Lang)

macOS 12 arm64, problem also started showing up after an update. Deactivate & re-activate of the port fixed it.

Maybe it's related to the space in the filename? Can somebody who still has the problem check whether these other files still exist?

/opt/local/share/git-gui/lib/Git Gui.app/Contents/Info.plist
/opt/local/share/git-gui/lib/Git Gui.app/Contents/Resources/Scripts/AppMain.tcl
/opt/local/share/git-gui/lib/Git Gui.app/Contents/Resources/git-gui.icns

rev-upgrade wouldn't scan those other files since they're not binaries, so we might not notice immediately if they're gone.

comment:13 Changed 5 months ago by mf2k (Frank Schima)

Those files do not exist for me. The entire Git Gui.app was apparently deleted during my last update.

comment:14 Changed 5 months ago by michaellass (Michael Lass)

Cc: michaellass added

comment:15 Changed 4 months ago by jowens (John Owens)

Cc: jowens added

comment:16 Changed 4 months ago by i0ntempest

Cc: i0ntempest added

comment:17 Changed 4 months ago by Schamschula (Marius Schamschula)

Cc: Schamschula added

comment:18 Changed 4 months ago by fracai

Cc: fracai added

comment:19 Changed 4 months ago by blair (Blair Zajac)

Cc: blair added

comment:20 Changed 4 months ago by iay (Ian Young)

Cc: iay added

comment:21 Changed 4 months ago by catap (Kirill A. Korinsky)

Cc: catap added

comment:22 Changed 4 months ago by hnarayanan (Harish Narayanan)

Cc: hnarayanan added

comment:23 Changed 4 months ago by ryandesign (Ryan Schmidt)

Has [4bfc47deb6919ff5a90fdf8c6b90317586324322/macports-ports] helped with this problem? Let us know if you still see the problem after updating to git @2.35.2_1.

comment:24 Changed 4 months ago by ylluminate (ylluminate)

I also have been hit by this after an update to 12.4ß1. It appears as though the suggested deactivation + activation resolved it for the time being...

comment:25 Changed 4 months ago by ylluminate (ylluminate)

Cc: ylluminate added

comment:26 Changed 3 months ago by i0ntempest

The update to 12.4b3 did not make this reappear. So I guess it's fixed?

Note: See TracTickets for help on using tickets.