Opened 15 years ago

Closed 15 years ago

#6511 closed defect (worksforme)

cdb 0.75 fails to build, "./compile" does not find "cdbget.c"

Reported by: bugz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: olegb@…, tristan@…
Port:

Description

A strange error message, that told me it cannot found cdbget.c. Due to my lack of experience in this field, I can only guess, that it is simple to remove or workaround, but I don't know how.

Port Version: 1.200

Here is the output of port -d -v cdb:

http://www.bonnzept.de/irdisch/cdb-err-output-d-v.html

and here the output of port -d -v cdb (with "make -d" as build.cmd in the portfile):

http://www.bonnzept.de/irdisch/cdb-err-output-d-v-make-d.html

I could at least resolve the error with the head command, by replacing all occurences of "head -1" to "head -c 1" in the Makefile of cdb, like the manual page of head tells me:

NAME

head -- display first lines of a file

SYNOPSIS

head [-n count] [file ...]

So this is specific part of the problem is probably an bug with different versions of head on Mac OS X 10.4 and other Unixes ?!? Version of head: "This is lwp-request version 2.06 (libwww-perl-5.803)"

Change History (2)

comment:1 Changed 15 years ago by olegb@…

Cc: olegb@… added

cdb builds/installs fine on 10.4.5 (xc2.2)

comment:2 Changed 15 years ago by markd@…

Resolution: worksforme
Status: newclosed

(In reply to comment #1)

cdb builds/installs fine on 10.4.5 (xc2.2)

Using 10.4.5 I an't duplicate it either. Closing.

Note: See TracTickets for help on using tickets.