Opened 3 months ago

Closed 4 weeks ago

#65410 closed defect (fixed)

py-pyqt5: fails to find the appropriate SDK for Big Sur and Monterey

Reported by: mouse07410 (Mouse) Owned by: reneeotten (Renee Otten)
Priority: Normal Milestone:
Component: ports Version: 2.7.2
Keywords: bigsur monterey Cc: mascguy (Christopher Nielsen), paspro (Panos Asproulis), amake (Aaron Madlon-Kay), odysseus9672 (Sean Lake), StanSanderson, stephanmg (Stephan Grein), hapaguy (Brian Kurt Fujikawa), HowieChun, chrstphrchvz (Christopher Chavez), mike142wood, RafalLukawiecki (Rafal Lukawiecki), cooljeanius (Eric Gallager), kgarrels, Oscarabranches, adamgao1996, franc-gontier (dc66)
Port: py-pyqt5

Description

MacOS 12.4, Xcode-13.4.1. Error:

:info:build /opt/local/libexec/qt5/bin/qmake -recursive PyQt5.pro
:info:build sip-build-3.10: '/opt/local/libexec/qt5/bin/qmake -recursive PyQt5.pro' failed returning 3
:info:build Project ERROR: Could not resolve SDK Path for 'macosx12' using --show-sdk-path
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-pyqt5/py310-pyqt5/work/PyQt5-5.15.7" && sip-build-3.10 --qmake /opt/local/libexec/qt5/bin/qmake --verbose --confirm-license --dbus=/opt/local/Library/Frameworks/Python.framework/Versions/3.10/include/python3.10/dbus-1.0 --disable QtWebKit --disable QtWebKitWidgets 
:info:build Exit code: 1
:error:build Failed to build py310-pyqt5: command execution failed
:debug:build Error code: CHILDSTATUS 28301 1

What's loaded on this machine:

$ xcrun --show-sdk-path
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk
$ ll /Library/Developer/CommandLineTools/SDKs/
total 0
drwxr-xr-x  7 root  wheel  224 May 12 22:37 ./
drwxr-xr-x  5 root  wheel  160 Mar 20 11:54 ../
lrwxr-xr-x  1 root  wheel   14 May 12 22:36 MacOSX.sdk@ -> MacOSX12.3.sdk
drwxr-xr-x  7 root  wheel  224 May 12 22:37 MacOSX11.3.sdk/
lrwxr-xr-x  1 root  wheel   14 May 12 22:35 MacOSX11.sdk@ -> MacOSX11.3.sdk
drwxr-xr-x  7 root  wheel  224 May 12 22:37 MacOSX12.3.sdk/
lrwxr-xr-x  1 root  wheel   14 May 12 22:35 MacOSX12.sdk@ -> MacOSX12.3.sdk
$ 

Change History (30)

comment:1 Changed 3 months ago by mascguy (Christopher Nielsen)

Cc: mascguy added

comment:2 Changed 3 months ago by mascguy (Christopher Nielsen)

Cc: paspro added; reneeotten removed
Keywords: monterey added
Owner: set to reneeotten
Port: py-pyqt5 added; py310-pyqt5 removed
Status: newassigned
Summary: py310-pyqt5 fails to find the appropriate SDKpy-pyqt5: fails to find the appropriate SDK
Version: 2.7.2

comment:3 Changed 3 months ago by reneeotten (Renee Otten)

this is an issue with Qt5 and/or the PortGroups - see the discussion at the commit and linked Trac tickets.

comment:4 Changed 3 months ago by mascguy (Christopher Nielsen)

Keywords: bigsur added
Summary: py-pyqt5: fails to find the appropriate SDKpy-pyqt5: fails to find the appropriate SDK for Big Sur and Monterey

comment:5 Changed 3 months ago by amake (Aaron Madlon-Kay)

Cc: amake added

comment:6 Changed 3 months ago by mf2k (Frank Schima)

Per discussion of this issue elsewhere, simply adding the following to the Portfile solves the problem for me:

use_xcode           yes

comment:7 Changed 3 months ago by mouse07410 (Mouse)

@Frank, I concur. Proposed workaround works on Monterey 12.4 with Xcode-13.4.1..

comment:8 Changed 3 months ago by reneeotten (Renee Otten)

Cc: odysseus9672 added

has duplicate 65422

comment:9 Changed 3 months ago by ryandesign (Ryan Schmidt)

Cc: StanSanderson added

Has duplicate #65426.

comment:10 Changed 3 months ago by mouse07410 (Mouse)

It looks like a circular "duplicate" has been introduced - all of these tickets are marked as "duplicate" of each other.

comment:11 Changed 3 months ago by ryandesign (Ryan Schmidt)

No, this ticket (#65410) is open. The others are closed as duplicates of this ticket.

comment:12 Changed 3 months ago by ryandesign (Ryan Schmidt)

Cc: stephanmg added

Has duplicate #65441.

comment:13 Changed 3 months ago by stephanmg (Stephan Grein)

Thanks @Frank, this seems to work for me as well. (#65441 is a duplicate and can be closed)

(I edited the Portfile in /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/python/py-pyqt5)

Last edited 3 months ago by stephanmg (Stephan Grein) (previous) (diff)

comment:14 Changed 3 months ago by StanSanderson

I would edit the Portfile if I had a clue how to do it without breaking everything. Patience (i.e., waiting for the Portfile owner to submit a revision) appears to be the key. I'm too used to Ports "just working."

comment:15 Changed 3 months ago by hapaguy (Brian Kurt Fujikawa)

Cc: hapaguy added

comment:16 Changed 2 months ago by mascguy (Christopher Nielsen)

Cc: HowieChun added

comment:17 Changed 2 months ago by mascguy (Christopher Nielsen)

Has duplicate issue:65490

comment:18 Changed 2 months ago by StanSanderson

OK, I used BBedit to insert "use_xcode yes" into the py39-pyqt5 port file at a likely spot and yes, the file updated. However, as expected, all of the affected port files would have to be modified. The discussions I've seen refer to possible problems resulting from the rogue editing, so I have only changed the port file on my iMac, and only for the py39-pyqt5 file. Until something breaks, I'll avoid the china shop.

comment:19 Changed 2 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:20 Changed 2 months ago by mascguy (Christopher Nielsen)

This issue is blocking builds for a number of dependents.

Renee, any thoughts/updates, relative to fixing...?

comment:21 Changed 2 months ago by mouse07410 (Mouse)

In my opinion, adding use_xcode yes to the each relevant Portfile is the simplest option, and probably least harmful in the long run.

comment:22 in reply to:  20 Changed 2 months ago by reneeotten (Renee Otten)

Replying to mascguy:

Renee, any thoughts/updates, relative to fixing...?

as discussed at many places, the issue is not specific to this port or any other individual port depending on Qt5, but related to how the Qt5 handles the detection of the SDK. This is something that should be fixed correctly, most likely in the qt5 PortGroup. However, in theory there shouldn't be a reason to require a full XCode installation anywhere and for sure not on older systems where everything works fine.

Having said that I changed jobs and am not using a Mac as my primary system anymore. I will continue to update "my" ports and try to contribute where I can, but this specific problem is not something I will work on. So if the MacPort project decides that, for the lack of a better solution, adding use_xcode yes in the qt5 PG (perhaps conditionally for only the newer systems where these failures are observed) is the appropriate thing to do, the feel free to do so.

comment:23 Changed 2 months ago by mike142wood

Cc: mike142wood added

comment:24 Changed 2 months ago by RafalLukawiecki (Rafal Lukawiecki)

Cc: RafalLukawiecki added

comment:25 Changed 2 months ago by cooljeanius (Eric Gallager)

Cc: cooljeanius added

comment:26 Changed 2 months ago by mascguy (Christopher Nielsen)

Cc: kgarrels added

comment:27 Changed 2 months ago by chrstphrchvz (Christopher Chavez)

PR opened to add use_xcode yes for OS versions + default Qt5 versions experiencing the error : https://github.com/macports/macports-ports/pull/15535

comment:28 Changed 7 weeks ago by mascguy (Christopher Nielsen)

Cc: Oscarabranches adamgao1996 franc-gontier added

comment:29 Changed 7 weeks ago by chrstphrchvz (Christopher Chavez)

In f29b28e6e9b68d4f8e11afdc78054aa5e4dd3252/macports-ports (master):

py-pyqt5: use_xcode yes, qt5.min_version 5.6

See: #65410

[skip ci]

comment:30 Changed 4 weeks ago by reneeotten (Renee Otten)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.