Opened 15 years ago

Closed 15 years ago

#6565 closed defect (fixed)

UPDATE: rxvt-unicode fails to build using Xcode 2.2

Reported by: jraitala@… Owned by: pesco@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

rxvt-unicode build failed in linking phase. Googling the error message (/usr/bin/ld: Undefined symbols: Unwind_Resume etc.) led me to http://www.cocoabuilder.com/archive/message/xcode/ 2005/11/21/1354 which suggested that problem might be caused by using gcc as linker instead of g+ + when linking to C++ code. I tried linking with g++ and were successful.

Before fixing the issue I tried to upgrade the Portfile to the latest ustream version; that's why the following fix includes an upstream version bump. Here's the updated Portfile altogether with my fix included as the three last rows:

PortSystem 1.0 name rxvt-unicode version 7.0 categories x11 maintainers pesco@… description Unicode-aware rxvt clone. long_description rxvt-unicode is a clone of the well-known terminal \

emulator rxvt. Some of it's main features over rxvt are \ use of UCS-2 or UCS-4 to store text internally, \ locale-correct in- and output, stability, \ completely flicker-free \ display, support for Xft and core fonts in any \ combination, etc.

homepage http://software.schmorp.de/#rxvt-unicode

master_sites http://dist.schmorp.de/rxvt-unicode/ \

http://dist.schmorp.de/rxvt-unicode/Attic/

depends_lib lib:libX11.6:XFree86 lib:libfreetype.6:freetype \

lib:libXft.2:Xft2 lib:libXrender.1:xrender \ lib:libfontconfig.1:fontconfig lib:libz.1:zlib \ lib:libexpat.0:expat

use_bzip2 yes checksums rmd160 4054c921652ca0c940ec63d7cfedb4bc6ec12fec

configure.args --enable-everything --with-codeset=all \

--mandir=${prefix}/share/man

post-configure {

reinplace "s|LINK = gcc|LINK = g++|g" ${worksrcpath}/src/Makefile

}

Change History (1)

comment:1 Changed 15 years ago by mww@…

Resolution: fixed
Status: newclosed
Summary: rxvt-unicode fails to build using Xcode 2.2UPDATE: rxvt-unicode fails to build using Xcode 2.2

commited, though please next time 1.) attach 2.) a patch (diff -u old-Portfile new-Portfile)

thanks!

Note: See TracTickets for help on using tickets.