Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#661 closed defect (fixed)

NEW: procmail-3.22

Reported by: robert@… Owned by: michaelm@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: danielluke (Daniel J. Luke)
Port:

Description

procmail-3.22

Tarball attached including: Portfile files/patch-Makefile files/patch-Makefile.1 files/patch-config.h

Description: A local mail delivery agent

Homepage: http://www.procmail.org/

Comments: Created this port so I could use this program. I have left the maintainer blank because I don't have CVS access to the dports tree to maintain it, although, I would if I had access.

Attachments (2)

procmail-3.22.tar (20.0 KB) - added by robert@… 17 years ago.
ATTACHMENT: procmail-3.22
Portfile (2.7 KB) - added by robert@… 17 years ago.
ATTACHMENT: procmail-3.22 (new)

Download all attachments as: .zip

Change History (16)

Changed 17 years ago by robert@…

Attachment: procmail-3.22.tar added

ATTACHMENT: procmail-3.22

comment:1 Changed 17 years ago by robert@…

op_sys: AllMac OS X
rep_platform: Allppc

comment:2 Changed 17 years ago by michaelm@…

Resolution: fixed
Status: newclosed

committed, minor formatting changes and I put you as maintainer.

CVS access is not required to maintain a port, updates can be put in bugzilla and one of the committers will commit it for you, if you get a bunch of ports going and it becomes lots of hassle to do your updates, then it is worth getting commit access for you.

comment:3 Changed 17 years ago by michaelm@…

Resolution: fixed
Status: closedreopened

duplicate of 571, as I commented in that bug report, I didn't notice the 2 procmail ports, the other port seems to handle installation more cleanly...I'll assign this bug to me as well and if we could discuss who wants to maintain procmail, and what changes are needed to the Portfile that'd be great,

cheers

comment:4 Changed 17 years ago by michaelm@…

Owner: changed from darwinports-bugs@… to michaelm@…
Status: reopenednew

assigning to me

comment:5 Changed 17 years ago by danielluke (Daniel J. Luke)

I made an earlier attempt at getting a procmail port into the darwinports tree, and I've been asked to comment on this one.

Instead of patching config.h, Makefile, and Makefile.1 you can pass changes to the variables in build.args and install.args.

Since you change BASENAME in the Makefile, you don't need to patch BINDIR in Makefile.1 (as it's based on BASENAME). I'm also not sure that your install target patches are necessary (if you set BASENAME to ${destroot}${prefix} things will get built/installed there and then copied over by darwinports.

In my port, I didn't change the paths in config.h as I thought it would be confusing (but I could be swayed to like your version that puts the global procmailrc file in the darwinports 'etc' directory).

I see that your post.install installs some documentation that normally isn't installed with procmail. I can see how this might be a good idea to someone, but the man pages are pretty complete so I don't think this is necesary.

comment:6 Changed 17 years ago by robert@…

You're probably correct about the documentation. I got that idea/suggestion from looking at the FreeBSD port of procmail. So I figured I'd install it. It's really not needed as you state because the man pages are pretty good.

As for the patching, I had trouble getting the build.args and install.args to work correctly with this, and that's why I patched the files. I'm still a little new to the dports setup, so I'm still learning new things.

The global procmailrc should reside in /opt/local/etc so that it can never conflict with another possible procmail installation in the future (by Apple possibly). I think the etc files should reside under /opt/local (prefix) for all dports when possible.

If you want to maintain the final procmail port, that is fine. We should consolidate these two and put it in the dports tree.

comment:7 Changed 17 years ago by robert@…

Cc: dluke@… added

Added dluke@… to CC list.

Daniel, I forgot to CC you on my reply. Please see bug 661 for my reply, and we can clean up this port. I think I can get rid of the patch files I have. I just need to try some of the things you did in your Portfile and a couple added things to take care of the config.h changes.

comment:8 Changed 17 years ago by danielluke (Daniel J. Luke)

I actually don't care who maintains this (I'll do it if you want me to, or you can if you want to). Especially since procmail doesn't release all that often.

You're probably right about the config file placement (although personally, I installed the newer procmail to replace the Apple-supplied one and it was nice to not have to move/change my global procmail configuration).

So, if we combine your patch to config.h with my portfile, we probably have a good final.

comment:9 Changed 17 years ago by robert@…

Ok, I'll take a stab at changing this and post the new Portfile. Hopefully, this can be a single Portfile setup (I think it can). Then you can take a quick review of it, and if it seems good, we can get them to update the CVS repos with the new files.

Thanks!

Changed 17 years ago by robert@…

Attachment: Portfile added

ATTACHMENT: procmail-3.22 (new)

comment:10 Changed 17 years ago by robert@…

attachments.isobsolete: 01

comment:11 Changed 17 years ago by robert@…

Please update the mail/procmail CVS files with the new attachment. It's now a single Portfile definition. All patches under "files" can be removed now.

comment:12 Changed 17 years ago by michaelm@…

Resolution: fixed
Status: newclosed

comment:13 Changed 17 years ago by robert@…

Resolution: fixed
Status: closedreopened

Please delete the patch files under the "files" directory. They are no longer needed.

comment:14 Changed 17 years ago by michaelm@…

Resolution: fixed
Status: reopenedclosed

done, thanks

Note: See TracTickets for help on using tickets.