Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#685 closed defect (fixed)

RFE: add query-requires and query-variants targets to port

Reported by: jcorley1@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: jacobwinther@…
Port:

Description

I've created two new targets for port, one which queries for requirements and one which queries for variants. Here's what the output looks like.

% % port query-requires exim exim has build dependencies on:

perl5.8

exim has library dependencies on:

netinet-headers

exim has runtime dependencies on:

DarwinPortsStartup

% % port query-variants exim smtp-auth exiscan mysql maildir %

The only note I have to make is query-requires doesn't do anything with variants. I've attached a patch to add the new targets to the man page, Makefile, and port.tcl.

Jason

Attachments (8)

patch (1.4 KB) - added by jcorley1@… 17 years ago.
patch for port.1, Makefile, and port.tcl
portquery-requires.tcl (1.6 KB) - added by jcorley1@… 17 years ago.
query-requires target
portquery-variants.tcl (845 bytes) - added by jcorley1@… 17 years ago.
query-variants target
patch-port.tcl (2.8 KB) - added by jcorley1@… 17 years ago.
new patch to port to do these same two things
bigpatch (8.3 KB) - added by jcorley1@… 17 years ago.
patch to fix toc on Portfile upgrade, and add query-variants, query-dependencies, and query-installed
bigpatch.2 (8.3 KB) - added by jcorley1@… 17 years ago.
screwed up one thing in the last one
bigpatch-posttest (8.4 KB) - added by jcorley1@… 17 years ago.
patch needed slight adjustments due to the porttest.tcl commits
bigpatch-landonf (8.9 KB) - added by jcorley1@… 17 years ago.
patch with landon, et. al. suggestions incorporated

Download all attachments as: .zip

Change History (18)

Changed 17 years ago by jcorley1@…

Attachment: patch added

patch for port.1, Makefile, and port.tcl

Changed 17 years ago by jcorley1@…

Attachment: portquery-requires.tcl added

query-requires target

Changed 17 years ago by jcorley1@…

Attachment: portquery-variants.tcl added

query-variants target

Changed 17 years ago by jcorley1@…

Attachment: patch-port.tcl added

new patch to port to do these same two things

comment:1 Changed 17 years ago by jcorley1@…

attachments.isobsolete: 01

Changed 17 years ago by jcorley1@…

Attachment: bigpatch added

patch to fix toc on Portfile upgrade, and add query-variants, query-dependencies, and query-installed

comment:2 Changed 17 years ago by jcorley1@…

attachments.isobsolete: 01

comment:3 Changed 17 years ago by jcorley1@…

Cc: jacobwinther@… added

comment:4 Changed 17 years ago by jcorley1@…

* Bug 743 has been marked as a duplicate of this bug. *

Changed 17 years ago by jcorley1@…

Attachment: bigpatch.2 added

screwed up one thing in the last one

comment:5 Changed 17 years ago by jcorley1@…

attachments.isobsolete: 01

Changed 17 years ago by jcorley1@…

Attachment: bigpatch-posttest added

patch needed slight adjustments due to the porttest.tcl commits

comment:6 Changed 17 years ago by jcorley1@…

attachments.isobsolete: 01

Changed 17 years ago by jcorley1@…

Attachment: bigpatch-landonf added

patch with landon, et. al. suggestions incorporated

comment:7 Changed 17 years ago by jcorley1@…

attachments.isobsolete: 01

comment:8 Changed 17 years ago by jcorley1@…

After some feedback I've redone the patch with the following changes:

  • New port commands are:

port deps foo port installed port variants bar

  • toc has been renamed to contents

port contents baz

The patch includes some aesthetic cleanups and an update to the man page.

Jason

comment:9 Changed 17 years ago by jcorley1@…

Owner: changed from darwinports-bugs@… to landonf@…

comment:10 Changed 17 years ago by landonf@…

Resolution: fixed
Status: newclosed

Committed, thanks!

Note: See TracTickets for help on using tickets.