Opened 15 years ago

Closed 14 years ago

#7309 closed defect (fixed)

cyrus-impad install fails on dependency net-snmp

Reported by: amgine@… Owned by: opendarwin.org@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: jmpp@…, markd@…
Port:

Description

net-snmp 5.3, net/net-snmp (Variants: no_ssl, no_zlib, bzip2, server, darwin, ipv6, ksm) http://net-snmp.sourceforge.net/ Maintainers: opendarwin.org@…

cyrus-imapd 2.2.12, Revision 3, mail/cyrus-imapd (Variants: darwin_7, powerpc, murder) http://asg.web.cmu.edu/cyrus/ Maintainers: jmpp@…

amgines-Computer:~ amgine$ sudo port install cyrus-imapd Password: ---> Fetching zlib ---> Attempting to fetch zlib-1.2.3.tar.bz2 from http://www.zlib.net/ ---> Verifying checksum(s) for zlib ---> Extracting zlib ---> Configuring zlib ---> Building zlib with target all ---> Staging zlib into destroot ---> Packaging tgz archive for zlib 1.2.3_0 ---> Installing zlib 1.2.3_0 ---> Activating zlib 1.2.3_0 ---> Cleaning zlib ---> Fetching openssl ---> Attempting to fetch openssl-0.9.8a.tar.gz from http://www.openssl.org/source/ ---> Verifying checksum(s) for openssl ---> Extracting openssl ---> Applying patches to openssl ---> Configuring openssl ---> Building openssl with target all ---> Staging openssl into destroot ---> Packaging tgz archive for openssl 0.9.8a_0 ---> Installing openssl 0.9.8a_0 ---> Activating openssl 0.9.8a_0 ---> Cleaning openssl ---> Fetching cyrus-sasl2 ---> Attempting to fetch cyrus-sasl-2.1.21.tar.gz from http://ftp.andrew.cmu.edu/pub/cyrus-mail/ ---> Verifying checksum(s) for cyrus-sasl2 ---> Extracting cyrus-sasl2 ---> Applying patches to cyrus-sasl2 ---> Configuring cyrus-sasl2 ---> Building cyrus-sasl2 with target all ---> Staging cyrus-sasl2 into destroot ---> Packaging tgz archive for cyrus-sasl2 2.1.21_0 ---> Installing cyrus-sasl2 2.1.21_0 ---> Activating cyrus-sasl2 2.1.21_0 ---> Cleaning cyrus-sasl2 ---> Fetching db4 ---> Attempting to fetch db-4.3.29.tar.gz from http://downloads.sleepycat.com/ ---> Verifying checksum(s) for db4 ---> Extracting db4 ---> Configuring db4 ---> Building db4 with target all ---> Staging db4 into destroot ---> Packaging tgz archive for db4 4.3.29_0+darwin_7 ---> Installing db4 4.3.29_0+darwin_7 ---> Activating db4 4.3.29_0+darwin_7 ---> Cleaning db4 ---> Fetching net-snmp ---> Attempting to fetch net-snmp-5.3.tar.gz from http://puzzle.dl.sourceforge.net/net-snmp ---> Verifying checksum(s) for net-snmp ---> Extracting net-snmp ---> Applying patches to net-snmp ---> Configuring net-snmp ---> Building net-snmp with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_net_net-snmp/work/net-snmp-5.3" && make all" returned error 2 Command output: ld: warning prebinding disabled because dependent library: /opt/local/lib/libnetsnmp.10.dylib is not prebound creating snmpnetstat /bin/sh ../libtool --mode=compile gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c -o snmptrapd_handlers.lo snmptrapd_handlers.c gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c snmptrapd_handlers.c -fno-common -DPIC -o snmptrapd_handlers.lo /bin/sh ../libtool --mode=compile gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c -o snmptrapd_log.lo snmptrapd_log.c gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c snmptrapd_log.c -fno-common -DPIC -o snmptrapd_log.lo /bin/sh ../libtool --mode=compile gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c -o snmptrapd_auth.lo snmptrapd_auth.c gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -g -O2 -Ddarwin7 -c snmptrapd_auth.c -fno-common -DPIC -o snmptrapd_auth.lo In file included from snmptrapd_auth.c:10: /usr/include/netinet/in.h:255: error: parse error before "in_addr_t" /usr/include/netinet/in.h:312: error: parse error before "u_char" /usr/include/netinet/in.h:314: error: parse error before "sin_port" /usr/include/netinet/in.h:317: error: parse error before '}' token /usr/include/netinet/in.h:329: error: field `ip_dst' has incomplete type /usr/include/netinet/in.h:398: error: field `imr_multiaddr' has incomplete type /usr/include/netinet/in.h:399: error: field `imr_interface' has incomplete type In file included from /usr/include/netinet/in.h:518,

from snmptrapd_auth.c:10:

/usr/include/netinet6/in6.h:625: error: parse error before "inet6_rthdr_space" /usr/include/netinet6/in6.h:637: error: parse error before "size_t" /usr/include/netinet6/in6.h:639: error: parse error before "size_t" /usr/include/netinet6/in6.h:640: error: parse error before "size_t" /usr/include/netinet6/in6.h:641: error: parse error before "size_t" /usr/include/netinet6/in6.h:644: error: parse error before "size_t" /usr/include/netinet6/in6.h:646: error: parse error before "size_t" /usr/include/netinet6/in6.h:647: error: parse error before "size_t" /usr/include/netinet6/in6.h:648: error: parse error before "inet6_rth_space" /usr/include/netinet/in.h:315: error: storage size of `sin_addr' isn't known make[1]: * [snmptrapd_auth.lo] Error 1 make: * [subdirs] Error 1

Error: The following dependencies failed to build: net-snmp perl5.8 Error: /opt/local/bin/port: Status 1 encountered during processing.

Attachments (2)

Portfile.diff (828 bytes) - added by markd@… 14 years ago.
Portfile diff
patch-agent.mibgroup.host.hr_storage.c (540 bytes) - added by markd@… 14 years ago.
5.3.1 patchfile for hr_strorage.c

Download all attachments as: .zip

Change History (9)

comment:1 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to opendarwin.org@…

Assigning to maintainer.

comment:2 Changed 15 years ago by jmpp@…

Cc: jmpp@… added

I am the maintainer of the cyrus-imapd port and have some pending updates to it (mostly Tiger related), so even though this is not exactly a bug of mine, I'm Cc'ing myself to it just in case.

-jmpp

comment:3 Changed 15 years ago by darwin-bugzilla@…

Current net-snmp source will build unmodified on 10.4.5 with configure defaults, so the root cause of the breakage in the net-snmp Portfile is probably in its args to configure

comment:4 Changed 14 years ago by opendarwin.org@…

net-snmp has been upgraded to 5.3.0.1, please test.

comment:5 Changed 14 years ago by irvine@…

(In reply to comment #4)

net-snmp has been upgraded to 5.3.0.1, please test.

I am having the same problem installing on 10.3.9. Version 5.3.0.1 gives the same error.

comment:6 Changed 14 years ago by markd@…

Cc: markd@… added

I verified the problem on 10.3.x. I tried the new NET-SNMP 5.3.1 and it now compiles cleanly on 10.3.x. I attached patchfiles to update the port.

Changed 14 years ago by markd@…

Attachment: Portfile.diff added

Portfile diff

Changed 14 years ago by markd@…

5.3.1 patchfile for hr_strorage.c

comment:7 Changed 14 years ago by ghosthound

Resolution: fixed
Status: newclosed

net-snmp (5.4 even) now compiles fine on 10.4, I believe this problem is resolved. Please re-open if it is not.

Note: See TracTickets for help on using tickets.