Opened 15 years ago

Closed 14 years ago

#7482 closed defect (fixed)

BUG: gnome-panel 2.12.2 does not see png

Reported by: yves@… Owned by: gnome-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description

I try to set an icon to a panel-launcher (through the properties dialog) and /opt/local/share/pixmaps which is full of png files appears empty in the file browser

I have png previews working in nautilus, though

Attachments (1)

gnome-splash.png (192.3 KB) - added by yves@… 15 years ago.
a dp-gnome-splash

Download all attachments as: .zip

Change History (18)

comment:1 Changed 15 years ago by yves@…

there is one more thing ... icons inside the menus are displayed OK

comment:2 Changed 15 years ago by yves@…

I did not say everything ... I get no splash at gnome startup

comment:3 Changed 15 years ago by yves@…

Well, the splash-screen is now showing. I guess it did not yesterday because I had stuff compiling in the background and it does not last long.

Changed 15 years ago by yves@…

Attachment: gnome-splash.png added

a dp-gnome-splash

comment:4 Changed 15 years ago by blb@…

Cc: gnome-darwinports@… removed
Owner: changed from darwinports-bugs@… to gnome-darwinports@…

Assigning to maintainer.

comment:5 Changed 15 years ago by rhwood@…

I am unable to recreate the problem you are having with PNGs.

Try this: sudo update-mime-database /opt/local/share/mime

I am trying to figure out the optimum port(s) to run that command in.

comment:6 Changed 15 years ago by rhwood@…

Please submit your splash-screen in a separate bug, labelled for GNOME 2.14 and I will get in there as I port that version of GNOME.

comment:7 Changed 15 years ago by yves@…

Try this: sudo update-mime-database /opt/local/share/mime

I don't have this command installed anywhere, to which port does it belong ?

comment:8 Changed 15 years ago by yves@…

attachments.isobsolete: 01

(From update of attachment 6770) does not belong here

comment:9 Changed 15 years ago by rhwood@…

Status: newassigned

gnome-panel needs a depends_build on shared-mime-data

comment:10 Changed 15 years ago by rhwood@…

(In reply to comment #8)

Try this: sudo update-mime-database /opt/local/share/mime

I don't have this command installed anywhere, to which port does it belong ?

this command is provided by port shared-mime-data

comment:11 Changed 15 years ago by yves@…

mmm, would you bet on it ?

Bilbo:~ yves$ sudo port install shared-mime-data Password: Error: Port shared-mime-data not found Bilbo:~ yves$ port search mime shared-mime-info devel/shared-mime-info 0.15 Database of common types. gnome-mime-data gnome/gnome-mime-data 2.4.2 This module contains the base MIME and Application database for GNOME.

comment:12 Changed 15 years ago by yves@…

it really is shared-mime-info, I fixed the Portfile

Maybe the Portfile also needs

export XDG_DATA_DIRS=/opt/local/share export XDG_CONFIG_DIRS=/opt/local/etc/xdg

?

comment:13 Changed 15 years ago by rhwood@…

(In reply to comment #13)

export XDG_DATA_DIRS=/opt/local/share export XDG_CONFIG_DIRS=/opt/local/etc/xdg

dump these in your .profile and/or .xinitrc file(s) to ensure that they work.

comment:14 Changed 15 years ago by yves@…

(In reply to comment #14)

(In reply to comment #13)

export XDG_DATA_DIRS=/opt/local/share export XDG_CONFIG_DIRS=/opt/local/etc/xdg

dump these in your .profile and/or .xinitrc file(s) to ensure that they work.

I mean the post-install command wil also need these variables to work, so it might be better no to bet that they are already in the user's .profile

And shouldn't it be be post-activate ?

comment:15 Changed 15 years ago by rhwood@…

The warnings thrown by update-mime-database seem to be just that warnings. The port command does not seem to be affected one way or the other by the XDG_* environment variables.

Since gnome-panel does not install any mime information of its own, and is just a consumer of mime data, post-install or post-activate can be used without ill effect.

comment:16 Changed 14 years ago by rhwood@…

Can this error still be reproduced?

comment:17 Changed 14 years ago by yves@…

Resolution: fixed
Status: assignedclosed

as far as I know, adding shared-mime-info dependency fixed the problem

Note: See TracTickets for help on using tickets.