Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#757 closed defect (fixed)

reinplace doesn't handle unwritable original files

Reported by: fenner@… Owned by: fkr@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc:
Port:

Description

While trying to port rlpr, I found that reinplace doesn't handle non-writable files. The command

reinplace s,/etc/rlprrc,${prefix}/etc/rlprrc, \

${worksrcpath}/man/rlpq.1

resulted in

Error: reinplace: cp: /Users/fenner/dports/rlpr/work/rlpr-2.04/man/rlpq.1: Permission denied

I worked around it with system "chmod +w" but it'd be nice if reinplace could handle it itself.

Attachments (1)

portutil.tcl.patch (674 bytes) - added by fenner@… 15 years ago.
Proposed patch to portutil.tcl

Download all attachments as: .zip

Change History (4)

comment:1 Changed 15 years ago by fenner@…

Oddly enough, I ran into this already and solved it with file attributes $file -permissions +w For some reason this time I thought it had to be done with system("chmod"). Since it can be done in tcl I'll attach a proposed patch.

Changed 15 years ago by fenner@…

Attachment: portutil.tcl.patch added

Proposed patch to portutil.tcl

comment:2 Changed 15 years ago by fkr@…

Owner: changed from darwinports-bugs@… to fkr@…

comment:3 Changed 15 years ago by fkr@…

Resolution: fixed
Status: newclosed

comitted! thanks, bill. -fkr

Note: See TracTickets for help on using tickets.