Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#7759 closed defect (fixed)

BUG: advi build fails

Reported by: yves@… Owned by: pmq@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description (last modified by mf2k (Frank Schima))

First I got :

ocamlc -warn-error A -g -I /opt/local/lib/ocaml/camlimages -c misc.ml
File "misc.ml", line 117, characters 5-6:
Warning Y: unused variable l.
File "misc.ml", line 183, characters 6-9:
Warning Y: unused variable len.
File "misc.ml", line 195, characters 6-41:
Warning X: this statement never returns.

Error: error-enabled warnings (3 occurrences)
make: *** [misc.cmo] Error 2

So I removed the -warn-error flag, then I got :

ocamlc -g -custom -I /opt/local/lib/ocaml/camlimages events.o grwm.o grY11.o graphics.cma unix.cma str.cma ci_core.cma graphics.cma ci_graphics.cma ci_freetype.cma ci_gif.cma ci_jpeg.cma ci_tiff.cma ci_bmp.cma ci_ppm.cma ci_png.cma ci_xvthumb.cma ci_xpm.cma ci_ps.cma config.cmo misc.cmo timeout.cmo ageometry.cmo options.cmo rc.cmo userfile.cmo graphicsY11.cmo global_options.cmo busy.cmo gradient.cmo gterm.cmo launch.cmo dvicolor.cmo shot.cmo laser_pointer.cmo symbol.cmo input.cmo table.cmo pkfont.cmo ttfont.cmo jfm.cmo search.cmo font.cmo glyph.cmo devfont.cmo units.cmo dimension.cmo dvi.cmo drawimage.cmo gs.cmo transimpl.cmo embed.cmo grdev.cmo addons.cmo scratch.cmo cdvi.cmo driver.cmo thumbnails.cmo dviview.cmo main.cmo  -cclib -lgraphics -cclib -lunix -cclib -lstr -cclib -L/usr/X11R6/lib -cclib -lSM -cclib -lICE -cclib -lXinerama -cclib -lXext -cclib -lX11 -o advi.byt
/usr/bin/ld: warning prebinding disabled because dependent library: /opt/local/lib/libungif.4.dylib is not prebound
/usr/bin/ld: multiple definitions of symbol _caml_gr_resize_window
grY11.o definition of _caml_gr_resize_window in section (__TEXT,__text)
/opt/local/lib/ocaml/libgraphics.a(open.o) definition of _caml_gr_resize_window in section (__TEXT,__text)
collect2: ld returned 1 exit status
Error while building custom runtime system
make: *** [advi.byt] Error 2

Attachments (1)

advi-1.6.0_1.diff (1.9 KB) - added by pierre@… 15 years ago.
Portfile patch

Download all attachments as: .zip

Change History (8)

comment:1 Changed 15 years ago by blb@…

Cc: pierre@… removed
Owner: changed from darwinports-bugs@… to pierre@…

Assigning to maintainer.

comment:2 Changed 15 years ago by pierre@…

Just letting you know that I'll try to reproduce/fix that this week-end. Sorry for the inconvenience. -- Pierre

comment:3 Changed 15 years ago by pierre@…

Thanks for the bug report. I can reproduce it. I spent a little time on that, and I have absolutely no idea what's happening, nor why this would happen with no version bumps in camlimages & advi. If someone there is more skilled than I am, I'm ready to orphan/transfer maintainership for advi. I will have a rough time at work in the coming months, so I won't be able to deal with this issue with the needed amount of work.

comment:4 Changed 15 years ago by pierre@…

I spent some time creating a patch, but it quickly became quite long. I tried Debian's patch, but it doesn't resolve some quirks (warnings). So I used the CVS version, which also corrects some other stuff (typos in docs, minor fixes...). FYI, advi-1.7 is announced in the notes in the CVS version, but has never been officially released, so the tarball is really old. Tell me how it works for you. Patch attached. -- Pierre

Changed 15 years ago by pierre@…

Attachment: advi-1.6.0_1.diff added

Portfile patch

comment:5 Changed 14 years ago by pmq@…

Owner: changed from pierre@… to pmq@…

Will commit either when my CVS account is fixed, or switch to subversion is effective.

comment:6 Changed 14 years ago by pmq@…

Resolution: fixed
Status: newclosed

Committed my fix, as it seems to be working fine.

comment:7 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)
Note: See TracTickets for help on using tickets.