Opened 15 years ago

Closed 15 years ago

#7811 closed defect (fixed)

BUG: Ghostscript font checksum mismatches

Reported by: anejr@… Owned by: digdog@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: aschenke@…, yesthatjwz (Jamie Zawinski), markd@…, takanori@…, lucas@…
Port:

Description

I tried installing ghostscript several times this evening. This is the last session. Notice that I did a clean --all to be sure to get a fresh start.

alsmini:~/Development al$ sudo port clean --all ghostscript Password: ---> Cleaning ghostscript alsmini:~/Development/RonRailsDev/tiny_file al$ sudo port install ghostscript ---> Fetching ghostscript ---> Attempting to fetch ghostscript-8.53.tar.gz from http://puzzle.dl.sourceforge.net/ghostscript ---> Attempting to fetch ghostscript-8.53.tar.gz from http://mesh.dl.sourceforge.net/ghostscript ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://puzzle.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://mesh.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-other-6.0.tar.gz from http://puzzle.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-other-6.0.tar.gz from http://mesh.dl.sourceforge.net/gs-fonts ---> Attempting to fetch jpegsrc.v6b.tar.gz from http://www.ijg.org/files/ ---> Attempting to fetch libpng-1.2.8.tar.gz from http://puzzle.dl.sourceforge.net/libpng ---> Attempting to fetch libpng-1.2.8.tar.gz from http://mesh.dl.sourceforge.net/libpng ---> Attempting to fetch zlib-1.2.3.tar.gz from http://www.zlib.net/ ---> Attempting to fetch aj16.tar.Z from http://examples.oreilly.de/english_examples/nutshell/cjkv/adobe/ ---> Attempting to fetch ag14.tar.Z from http://examples.oreilly.de/english_examples/nutshell/cjkv/adobe/ ---> Attempting to fetch ac15.tar.Z from http://examples.oreilly.de/english_examples/nutshell/cjkv/adobe/ ---> Attempting to fetch ak12.tar.Z from http://examples.oreilly.de/english_examples/nutshell/cjkv/adobe/ ---> Verifying checksum(s) for ghostscript Error: Checksum (md5) mismatch for ghostscript-fonts-std-8.11.tar.gz Error: Checksum (md5) mismatch for ghostscript-fonts-other-6.0.tar.gz Error: Target com.apple.checksum returned: Unable to verify file checksums Error: /opt/local/bin/port: Status 1 encountered during processing.

Attachments (2)

ghostscript.diff (808 bytes) - added by takanori@… 15 years ago.
ghostscript.diff
aj16.diff (12.4 KB) - added by takanori@… 15 years ago.
aj16.diff

Download all attachments as: .zip

Change History (15)

comment:1 Changed 15 years ago by markd@…

Cc: markd@… added
Owner: changed from darwinports-bugs@… to digdog@…

I can verify this problem. In ghostscript port:

ghostscript-fonts-other md5 checksum should be: dc316bf89104ca6121ddb22a707b1191

ghostscript-fonts-std md5 checksum should be: d7635518fc6e369451a84e6b6661cd1d

Assigning to port maintainer.

comment:2 Changed 15 years ago by markd@…

(In reply to comment #1)

I can verify this problem. In ghostscript port:

ghostscript-fonts-other md5 checksum should be: dc316bf89104ca6121ddb22a707b1191

ghostscript-fonts-std md5 checksum should be: d7635518fc6e369451a84e6b6661cd1d

Oops. Check that. The checksums are correct. It may be a mirror issue, somehow bogus font files are being downloaded.

comment:3 Changed 15 years ago by mww@…

Summary: Ghostscript font checksum mismatchesBUG: Ghostscript font checksum mismatches

Changed 15 years ago by takanori@…

Attachment: ghostscript.diff added

ghostscript.diff

comment:4 Changed 15 years ago by takanori@…

Cc: takanori@… added

comment:5 Changed 15 years ago by digdog@…

This happened many times before, any files from sf.net could have this problems, so I won't think to place it at od as mirror is a good idea. (what if other sf.net files had mirror errors? should we also make a mirror at od too?)

comment:6 Changed 15 years ago by lucas@…

Cc: tuqueelukee@… added

* Bug 7905 has been marked as a duplicate of this bug. *

comment:7 Changed 15 years ago by blb@…

Cc: jwz@… added

* Bug 7906 has been marked as a duplicate of this bug. *

comment:8 Changed 15 years ago by blb@…

If it's just a sourceforge problem, perhaps dup it to bug 7484?

comment:9 Changed 15 years ago by aschenke@…

Cc: aschenke@… added

I agree with Bryan; this looks to be a duplicate of 7484. The original Portfile is working correctly for me since DP was updated to better handle the Sourceforge mirror problems. Is it still causing problems for anyone?

comment:10 Changed 15 years ago by iano@…

Yes, this happened to me today trying to get ghostscript for testing cairo.

Relevant lines:

---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://puzzle.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://mesh.dl.sourceforge.net/gs-fonts .... ---> Verifying checksum(s) for ghostscript Error: Checksum (md5) mismatch for ghostscript-fonts-std-8.11.tar.gz Error: Target com.apple.checksum returned: Unable to verify file checksums

comment:11 Changed 15 years ago by iano@…

Upgraded port 1.2 to port 1.2.1 Did sudo port clean --all ghostscript

Tried again, fonts were fine (though apparently hard to download), but now got a checksum error on aj16:

---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://puzzle.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://mesh.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://belnet.dl.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://optusnet.dl.sourceforge.net/gs-fonts ... ---> Attempting to fetch aj16.tar.Z from http://examples.oreilly.de/english_examples/nutshell/cjkv/adobe/ ... ---> Checksumming aj16.tar.Z Error: Checksum (md5) mismatch for aj16.tar.Z Portfile checksum: aj16.tar.Z md5 1d17e5f53d20ba8b8abcaeae3300aa26 Distfile checksum: aj16.tar.Z md5 b24ac1b6966adf3a92edaae42eda662c

Changed 15 years ago by takanori@…

Attachment: aj16.diff added

aj16.diff

comment:12 Changed 15 years ago by takanori@…

attachments.isobsolete: 01

comment:13 Changed 15 years ago by digdog@…

Resolution: fixed
Status: newclosed

okay, I updated the aj16.tar.Z checksum in Portfile, now version 1.2.2

Note: See TracTickets for help on using tickets.