New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #7815 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

BUG: reproducible lesspipe 1.52 crashes ksh

Reported by: rajiv@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: IngmarStein@…, markd@…
Port:

Description

running mac os x 10.4.5 build 8h14. installed lesspipe @1.51_0 with darwinports. put "eval lesspipe.sh" in my .bash_profile. each time less is run on a file that lesspipe.sh will parse, os x displays a crash dialog box for ksh:

Date/Time: 2006-03-17 00:25:51.164 -0500 OS Version: 10.4.5 (Build 8H14) Report Version: 4

Command: ksh Path: /bin/ksh Parent: less [5274]

Version: ??? (???)

PID: 5275 Thread: 0

Exception: EXC_BAD_ACCESS (0x0001) Codes: KERN_INVALID_ADDRESS (0x0001) at 0x000ff002

Thread 0 Crashed: 0 <<00000000>> 0xffff8acc memcpy + 812 (cpu_capabilities.h:189) 1 ksh 0x00063a84 0x1000 + 404100 2 ksh 0x00023318 0x1000 + 140056 3 ksh 0x000210b4 0x1000 + 131252 4 ksh 0x0002034c 0x1000 + 127820 5 ksh 0x00009240 0x1000 + 33344 6 ksh 0x00015b30 0x1000 + 84784 7 ksh 0x00016da4 0x1000 + 89508 8 ksh 0x0003af0c 0x1000 + 237324 9 ksh 0x00019360 0x1000 + 99168 10 ksh 0x000163e4 0x1000 + 87012 11 ksh 0x00017728 0x1000 + 91944 12 ksh 0x00004084 0x1000 + 12420 13 ksh 0x000033a8 0x1000 + 9128 14 ksh 0x00001ea8 0x1000 + 3752 15 ksh 0x00001d48 0x1000 + 3400

Thread 0 crashed with PPC Thread State 64:

srr0: 0x00000000ffff8acc srr1: 0x000000000200d930 vrsave: 0x00000000ff000000

cr: 0x24822446 xer: 0x0000000000000007 lr: 0x0000000000063a84 ctr: 0x0000000000003536 r0: 0x0000000000000000 r1: 0x00000000bfff9dc0 r2: 0x0000000000000000 r3: 0x0000000000209d74 r4: 0x00000000000ff002 r5: 0x00000000000e2106 r6: 0x0000000000000010 r7: 0x0000000000000020 r8: 0x0000000000000030 r9: 0x000000000000000c r10: 0x0000000000000060 r11: 0x0000000000000080

r12: 0x0000000000217100 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x00000000000e2ea0 r16: 0x0000000000000000 r17: 0x0000000000000000 r18: 0x0000000000000000 r19: 0x00000000000e72ea r20: 0x0000000000000000 r21: 0x0000000000000000 r22: 0x00000000000f0ec8 r23: 0x00000000000e72ea r24: 0x0000000000000020 r25: 0x00000000000e1070 r26: 0x0000000000000000 r27: 0x00000000000f0ef8 r28: 0x00000000000f1c36 r29: 0x00000000000e2112 r30: 0x00000000000d2990 r31: 0x00000000000e2112

Binary Images Description:

0x1000 - 0xd1fff ksh /bin/ksh

0x8fe00000 - 0x8fe54fff dyld 44.2 /usr/lib/dyld 0x90000000 - 0x901b3fff libSystem.B.dylib /usr/lib/libSystem.B.dylib 0x9020b000 - 0x9020ffff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib 0x92d08000 - 0x92df6fff libiconv.2.dylib /usr/lib/libiconv.2.dylib

downloading lesspipe 1.52 from http://www-zeuthen.desy.de/~friebel/unix/lesspipe.html and using that version instead prevents these crashes.

please bump lesspipe to 1.52. thanks

Attachments

Portfile.diff (778 bytes) - added by IngmarStein@… 8 years ago.
Portfile upgrade for 1.52
Portfile.2.diff (771 bytes) - added by IngmarStein@… 8 years ago.
Portfile diff
Portfile.3.diff (771 bytes) - added by IngmarStein@… 8 years ago.
lesspipe using /bin/bash

Change History

Changed 8 years ago by IngmarStein@…

Portfile upgrade for 1.52

comment:1 Changed 8 years ago by mww@…

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from reproducible lesspipe 1.51 crashes ksh to BUG: reproducible lesspipe 1.51 crashes ksh

commited!

comment:2 Changed 8 years ago by rajiv@…

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Summary changed from BUG: reproducible lesspipe 1.51 crashes ksh to BUG: reproducible lesspipe 1.52 crashes ksh

still having this ksh crashing problem with lesspipe 1.52... here is the real issue:

during 'sudo port -d upgrade lesspipe':

[...] ---> Configuring lesspipe DEBUG: Executing com.apple.configure (lesspipe) DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_textproc_lesspipe/work/lesspipe-1.52" && ./configure --prefix=/opt/local --yes' checking file.../usr/bin/file

found GNU file4.10 (ok)

Using /bin/ksh from the list of available shells:

/bin/ksh /bin/zsh /bin/bash /bin/sh

checking lsbom.../usr/bin/lsbom checking bzip2.../opt/local/bin/bzip2 checking dpkg...not found checking rpm...not found checking rpm2cpio...not found checking cpio.../usr/bin/cpio checking unzip.../usr/bin/unzip checking cabextract...not found or not proper version checking mdir...not found checking mtype...not found checking mtoolstest...not found checking isoinfo...not found checking dvi2tty...not found checking groff.../usr/bin/groff checking pod2text.../usr/bin/pod2text checking pstotext...not found checking gs...not found checking nm.../usr/bin/nm checking html2text...not found checking pdftotext...not found checking antiword...not found checking unrtf...not found checking mp3info...not found lesspipe.sh with syntax highlighting created Please make sure to copy lesspipe.sh and code2color to /opt/local/bin ---> Building lesspipe with target all DEBUG: Executing com.apple.build (lesspipe) DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_textproc_lesspipe/work/lesspipe-1.52" && make all' ./configure --prefix=/opt/local --nomake --yes checking file.../usr/bin/file

found GNU file4.10 (ok)

Using /bin/ksh from the list of available shells:

/bin/ksh /bin/zsh /bin/bash /bin/sh

checking lsbom.../usr/bin/lsbom checking bzip2.../opt/local/bin/bzip2 checking dpkg...not found checking rpm...not found checking rpm2cpio...not found checking cpio.../usr/bin/cpio checking unzip.../usr/bin/unzip checking cabextract...not found or not proper version checking mdir...not found checking mtype...not found checking mtoolstest...not found checking isoinfo...not found checking dvi2tty...not found checking groff.../usr/bin/groff checking pod2text.../usr/bin/pod2text checking pstotext...not found checking gs...not found checking nm.../usr/bin/nm checking html2text...not found checking pdftotext...not found checking antiword...not found checking unrtf...not found checking mp3info...not found lesspipe.sh with syntax highlighting created Please make sure to copy lesspipe.sh and code2color to /opt/local/bin ---> Staging lesspipe into destroot [etc...]

so the configure process (and also 'make') is finding /bin/ksh before /bin/bash. lesspipe.sh from the web site is configured with /bin/bash and does not have the ksh crashing problem on os x (which is why i thought the new version fixes the problem).

i suggest two changes to this port:

  • run ./configure with '--shell=/bin/bash'. this will solve the crashing problem.
  • do not run 'make all', just 'make install'. the 'all' target reruns configure without any options so ksh gets pulled in again.

thanks

Changed 8 years ago by IngmarStein@…

Portfile diff

comment:3 Changed 8 years ago by IngmarStein@…

Somehow, your /bin/ksh seems to be broken. ksh works fine for me, but here's a patch that implements the changes you suggested.

Changed 8 years ago by IngmarStein@…

lesspipe using /bin/bash

comment:4 Changed 8 years ago by markd@…

  • Cc markd@… added
  • Status changed from reopened to closed
  • Resolution set to fixed

Committed, thanks!

Note: See TracTickets for help on using tickets.