Opened 15 years ago

Closed 14 years ago

Last modified 12 years ago

#7828 closed defect (fixed)

BUG: cdrtools port doesn't install on Mac Intel / Tiger 10.4.5

Reported by: hydrometeor@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description

the cdrtools port (version 2.01) does not install on a Mac Mini Intel running Tiger 10.4.5 ... the error output is included below.

port install cdrtools

---> Fetching cdrtools ---> Attempting to fetch cdrtools-2.01.tar.gz from ftp://ftp.berlios.de/pub/cdrecord/ ---> Verifying checksum(s) for cdrtools ---> Extracting cdrtools ---> Configuring cdrtools ---> Building cdrtools with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_sysutils_cdrtools/work/cdrtools-2.01" && gnumake all" returned error 2 Command output: W A R N I N G Messages like:

gmake[2]: Entering directory `/tmp/cdrtools-2.01/libschily' ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/cvmod.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/dat.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fcons.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fdown.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fdup.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/ffileread.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/ffilewrite.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fgetline.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fgetstr.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/file_raise.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fileclose.d: No such file or directory ....

are caused by a GNU make bug and not by the Schily makefile system.

The related bug has been reported to the GNU make maintainers in 1988 but as the bug has not yet been fixed, it seems that GNU make is unmaintained :-( A working highly portable make program is at ftp://ftp.berlios.de/pub/smake RULES/rules1.top:234: incs/Dcc.i386-darwin: No such file or directory RULES/rules.top:39: RULES/i386-darwin-cc.rul: No such file or directory RULES/rules.cnf:56: incs/i386-darwin-cc/Inull: No such file or directory RULES/rules.cnf:57: incs/i386-darwin-cc/rules.cnf: No such file or directory p incs/i386-darwin-cc gnumake: p: Command not found gnumake: [incs/i386-darwin-cc/Inull] Error 127 (ignored) /bin/sh: line 1: incs/i386-darwin-cc/Inull: No such file or directory gnumake: * [incs/i386-darwin-cc/Inull] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

Attachments (1)

Portfile (989 bytes) - added by bytestorm@… 14 years ago.
cdrtools 2.01.01a25

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 years ago by mww@…

Summary: cdrtools port doesn't install on Mac Intel / Tiger 10.4.5BUG: cdrtools port doesn't install on Mac Intel / Tiger 10.4.5

comment:2 Changed 15 years ago by blb@…

* Bug 7829 has been marked as a duplicate of this bug. *

comment:3 Changed 14 years ago by pipping@…

Milestone: Port Bugs

comment:4 Changed 14 years ago by bytestorm@…

I cannot reproduce this error (Intel c2d, MacOS 10.4.9, xcode 2.4.1). I have updated the port to build a version newer than the 3 year old version currently marked stable. This works for me, please test it (hopefully it works for you).

Changed 14 years ago by bytestorm@…

Attachment: Portfile added

cdrtools 2.01.01a25

comment:5 Changed 14 years ago by pipping@…

Resolution: fixed
Status: newclosed

probably fixed in r24243.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.