Opened 15 years ago

Closed 15 years ago

#7829 closed defect (duplicate)

cdrtools port doesn't install on Mac Intel / Tiger 10.4.5

Reported by: hydrometeor@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description

the cdrtools port (version 2.01) does not install on a Mac Mini Intel running Tiger 10.4.5 ... the error output is included below.

port install cdrtools

---> Fetching cdrtools ---> Attempting to fetch cdrtools-2.01.tar.gz from ftp://ftp.berlios.de/pub/cdrecord/ ---> Verifying checksum(s) for cdrtools ---> Extracting cdrtools ---> Configuring cdrtools ---> Building cdrtools with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_sysutils_cdrtools/work/cdrtools-2.01" && gnumake all" returned error 2 Command output: W A R N I N G Messages like:

gmake[2]: Entering directory `/tmp/cdrtools-2.01/libschily' ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/cvmod.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/dat.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fcons.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fdown.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fdup.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/ffileread.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/ffilewrite.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fgetline.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fgetstr.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/file_raise.d: No such file or directory ../RULES/r-gmake.dep:76: OBJ/<arch-dir>/fileclose.d: No such file or directory ....

are caused by a GNU make bug and not by the Schily makefile system.

The related bug has been reported to the GNU make maintainers in 1988 but as the bug has not yet been fixed, it seems that GNU make is unmaintained :-( A working highly portable make program is at ftp://ftp.berlios.de/pub/smake RULES/rules1.top:234: incs/Dcc.i386-darwin: No such file or directory RULES/rules.top:39: RULES/i386-darwin-cc.rul: No such file or directory RULES/rules.cnf:56: incs/i386-darwin-cc/Inull: No such file or directory RULES/rules.cnf:57: incs/i386-darwin-cc/rules.cnf: No such file or directory p incs/i386-darwin-cc gnumake: p: Command not found gnumake: [incs/i386-darwin-cc/Inull] Error 127 (ignored) /bin/sh: line 1: incs/i386-darwin-cc/Inull: No such file or directory gnumake: * [incs/i386-darwin-cc/Inull] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 15 years ago by mww@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 7827 *

comment:2 Changed 15 years ago by ggaren@…

I think that dup number is wrong -- it's a WebKit bug.

comment:3 Changed 15 years ago by blb@…

Resolution: duplicate
Status: closedreopened

Reopening to dup it to the right bug.

comment:4 Changed 15 years ago by blb@…

Resolution: duplicate
Status: reopenedclosed

* This bug has been marked as a duplicate of 7828 *

Note: See TracTickets for help on using tickets.