Opened 15 years ago

Closed 14 years ago

Last modified 7 years ago

#7934 closed defect (fixed)

BUG: mod_fcgid-1.07 build fails - also needs updated.

Reported by: public@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…, james@…, bahamut@…
Port:

Description

I'm trying to build mod_fcgid on a 10.4.5 machine and getting a fialure during build seemingly due to an undefined constant (so I'm guessing a lib isn't getting included somewhere). I've isntalled fcgi and want to use it with apache2. Here's the dump of the error:

ethanwinn$ sudo port install mod_fcgid Password: Sorry, try again. Password: ---> Fetching mod_fcgid ---> Attempting to fetch mod_fcgid.1.07.tar.gz from http://fastcgi.coremail.cn/ ---> Verifying checksum(s) for mod_fcgid ---> Extracting mod_fcgid ---> Applying patches to mod_fcgid ---> Configuring mod_fcgid ---> Building mod_fcgid with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_www_mod_fcgid/work/mod_fcgid.1.07" && make all prefix=/opt/local" returned error 2 Command output: fcgid_bridge.c:362: error: 'HTTP_OK' undeclared (first use in this function) fcgid_bridge.c:367: error: 'HTTP_MOVED_TEMPORARILY' undeclared (first use in this function) fcgid_bridge.c: At top level: fcgid_bridge.c:381: error: parse error before '*' token fcgid_bridge.c: In function 'bridge_request': fcgid_bridge.c:384: error: 'r' undeclared (first use in this function) fcgid_bridge.c:385: error: 'server_rec' undeclared (first use in this function) fcgid_bridge.c:385: error: 'main_server' undeclared (first use in this function) fcgid_bridge.c:389: error: 'apr_bucket_brigade' undeclared (first use in this function) fcgid_bridge.c:389: error: 'output_brigade' undeclared (first use in this function) fcgid_bridge.c:390: error: 'apr_bucket' undeclared (first use in this function) fcgid_bridge.c:390: error: 'bucket_input' undeclared (first use in this function) fcgid_bridge.c:390: error: 'bucket_header' undeclared (first use in this function) fcgid_bridge.c:390: error: 'bucket_eos' undeclared (first use in this function) fcgid_bridge.c:392: warning: initialization makes pointer from integer without a cast fcgid_bridge.c:398: error: 'APLOG_MARK' undeclared (first use in this function) fcgid_bridge.c:398: error: 'APLOG_WARNING' undeclared (first use in this function) fcgid_bridge.c:401: error: 'HTTP_INTERNAL_SERVER_ERROR' undeclared (first use in this function) fcgid_bridge.c:425: error: 'input_brigade' undeclared (first use in this function) fcgid_bridge.c:431: error: 'AP_MODE_READBYTES' undeclared (first use in this function) fcgid_bridge.c:432: error: 'APR_BLOCK_READ' undeclared (first use in this function) fcgid_bridge.c:433: error: 'HUGE_STRING_LEN' undeclared (first use in this function) fcgid_bridge.c:434: error: 'APLOG_INFO' undeclared (first use in this function) fcgid_bridge.c:448: error: 'bucket_stdin' undeclared (first use in this function) fcgid_bridge.c:471: warning: assignment makes pointer from integer without a cast fcgid_bridge.c:475: error: 'apr_bucket_free' undeclared (first use in this function) fcgid_bridge.c:498: warning: assignment makes pointer from integer without a cast fcgid_bridge.c:524: error: 'argv0' undeclared (first use in this function) fcgid_bridge.c:524: error: 'wrapper_conf' undeclared (first use in this function) make: * [fcgid_bridge.slo] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (6)

comment:1 Changed 14 years ago by markd@…

Cc: markd@… added
Summary: mod_fcgid build failsBUG: mod_fcgid-1.07 build fails - also needs updated.

Yes I see this too. Some lib paths need to be patched and the port also needs updated to 1.10 because it has some OS X specific fixes.

comment:2 Changed 14 years ago by markd@…

Cc: james@… added

* Bug 8274 has been marked as a duplicate of this bug. *

comment:3 Changed 14 years ago by markd@…

Cc: bahamut@… added

* Bug 9672 has been marked as a duplicate of this bug. *

comment:4 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

Ok, I got the right includes listed in the portfile and it builds fine now. Also updated the port to 1.10 and added ui_msg's from previous submitted updates I marked as duplicates. Thanks everyone!

comment:5 Changed 14 years ago by bahamut@…

Be advised that I tested mod_fcgid 1.10 yesterday and the failure rate (HTTP 500 errors) has skyrocketed. I suspect it has to do with the select to poll change.

As we all know, poll behaves differently on Mac OS X 10.4. We've all seen it with Apache 2 and Subversion.

For the time being, I recommend staying with 1.09 or seeing if we can patch 1.10.

comment:6 Changed 14 years ago by markd@…

(In reply to comment #5)

Be advised that I tested mod_fcgid 1.10 yesterday and the failure rate (HTTP 500 errors) has skyrocketed. I suspect it has to do with the select to poll change.

As we all know, poll behaves differently on Mac OS X 10.4. We've all seen it with Apache 2 and Subversion.

For the time being, I recommend staying with 1.09 or seeing if we can patch 1.10.

I backed it down to 1.09 for now. I hope a fix can be worked out with the developers for future iteration of the module. Thank you.

Note: See TracTickets for help on using tickets.